Bug 239144 - four in a row network game dialog hangs machine for 60 seconds
four in a row network game dialog hangs machine for 60 seconds
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-05 05:03 EDT by David Timms
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 03:46:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 436305 None None None Never

  None (edit)
Description David Timms 2007-05-05 05:03:45 EDT
Description of problem:
In four in a row, network games is a menu option. Using it causes the machine to
become unresponsive for about a minute.

Version-Release number of selected component (if applicable):
gnome-games-2.18.0-5.fc7

How reproducible:
yes.

Steps to Reproduce:
1. gnect
2. game|network game
3. click profile text or drop down
  
Actual results:
mouse cursor can be moved and clicking on the drop down arrow stimulates the arrow.
you can not bring any other window into focus, including the gnome menus and
icons, nor move the network connection dialog of four in a row. None of the
window decoration commands nor the cancel / connect buttons are operable.
After about 60 seconds, you can continue.

Expected results:
minimal - disable the network profile drop down box so that an apparent machine
hang doesn't occur.
Be able to connect to a connect 4 network game.
Comment 1 David Timms 2007-05-05 05:14:47 EDT
nothing is logged to /var/log/messages.
The clock {showing seconds continues to run.
gkrellm shows that a few packets are sent on the network - this machine does
have internet connection and can dig the listed site ok:
;; ANSWER SECTION:
gnome.ggzgamingzone.org. 14400  IN      CNAME   oojah.dyndns.org.

possibly after the duration, a right click might be needed to get control back.
Comment 2 Andreas Røsdal 2007-05-06 05:48:34 EDT
Does this happen every time? What kind of network connection and computer do you
have? 

It might be possible that the server had high load at that time. Either way,
Four-in-a-row should handle connection problems more gracefully, with progress
bar indicators etc. 

I have reported this upstream to
http://bugzilla.gnome.org/show_bug.cgi?id=436305

Comment 3 Hans de Goede 2007-07-18 16:01:18 EDT
I can reproduce a long hang of the ggz application by changing the port of the
ggz server to a different (wrong) value and clicking connect. Unlike the
original description however I cannot reproduce this by clicking in the
combo-box, and when its reproduced by clicking on the connect button the window
freezes for a while, but the input is not grabbed as described in the combo-box
case, so other windows can still be navigated fine, seriously lowering the
severity of the problem.

Since this has also been reported upstream I would like to suggest to close this
bug with a resolution of upstream or wontfix (as it currently isn't that bad
anymore).

Comment 4 Hans de Goede 2007-07-25 03:46:58 EDT
Closing as upstream as per comment #3.

Note You need to log in before you can comment on or make changes to this bug.