Bug 239181 - Gnome shortcuts for volume in Acer Aspire laptop don't work
Gnome shortcuts for volume in Acer Aspire laptop don't work
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-05 14:16 EDT by Joe Pelayo
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 21:40:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sound card log file (139.49 KB, text/plain)
2007-05-09 20:25 EDT, Joe Pelayo
no flags Details

  None (edit)
Description Joe Pelayo 2007-05-05 14:16:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Description of problem:
When configuring Gnome's keyboard shortcuts to change the volume in my laptop (Acer Aspire 5102WLMi) they are assigned but don't work. Sometimes when trying to load ALSA Mixer it does not work either.
Shortcuts don't work even when selecting the "Acer Travelmate 800" in Keyboard Preferences. By the way I tried to assign the same shortcuts to different actions and they worked.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.Select "Acer Travelmate 800" in Keyboard Preferences.
2.Configure the shortcuts for volume in "Keyboard shortcuts"
3.Try to change the volume using them.

Actual Results:
I could not change the volume (shortcuts did not work)

Expected Results:
Volume should have changed through the shortcuts.

Additional info:
When trying to run alsamixer I get:
alsamixer: function snd_mixer_load failed: Invalid argument

I am also unable to use the WINDOWS key, which I usually use to switch between keyboard layouts.

In other Linux distributions the problem is not present.
Comment 1 Joe Pelayo 2007-05-05 14:24:00 EDT
This is my laptop's Smolt profile. Even though the problems where experienced in
Fedora 7 Test 4 (and the Smolt profile was taken in Fedora Core 6) I think it
will provide useful hardware information.
http://smolt.fedoraproject.org/show?UUID=647bd2bd-d776-49eb-a03b-be967a513e2a
Comment 2 David Zeuthen 2007-05-05 16:27:45 EDT
$ rpm -qf `which gnome-keybinding-properties`
control-center-2.18.0-12.fc7
Comment 3 Bastien Nocera 2007-05-09 08:33:23 EDT
> When trying to run alsamixer I get:
> alsamixer: function snd_mixer_load failed: Invalid argument

That looks bad, and driver/alsa-lib related.
Comment 4 Martin Stransky 2007-05-09 08:40:43 EDT
please run system-config-soundcard, switch to "System" page, generate the
/root/scsconfig.log and attach it here. /root/scsrun.log may help, too.
Comment 5 Joe Pelayo 2007-05-09 20:25:47 EDT
Created attachment 154441 [details]
Sound card log file

This is the log file generated in the "System" page of system-config-soundcard.

It was generated under FC6 though because right now I don't have the hard drive
where I installed F7 (but it is the sane laptop anyway). I hope it helps too.
Comment 6 Jussi Eloranta 2007-06-16 01:10:56 EDT
I see this problem too on my macmini with Apple Keyboard. I can configure the
volume keys (mute, vol down & up) but they do not work. Sound and volume control
works OK otherwise (not an ALSA problem). I had a similar problem on my Macbook
Pro earlier but I played around with some gnome config files (removing and
starting all over) and at some point the keys started working. I thought that
this might have been originated from FC6 (upgraded to F7). But the macmini had a
fresh F7 install and it still showed this problem. Interestingly, if I configure
eject (CDROM), it works perfectly.

Comment 7 Jussi Eloranta 2007-06-18 00:57:08 EDT
After the recent updates from yum, volume keys started working... so apparently
this is fixed now(?).
Comment 8 Bug Zapper 2008-04-03 20:32:48 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 9 Bug Zapper 2008-05-06 21:40:58 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

Note You need to log in before you can comment on or make changes to this bug.