Bug 239190 - Feature request: wired and wireless at the same time
Feature request: wired and wireless at the same time
Status: CLOSED DUPLICATE of bug 178276
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-05 16:23 EDT by François Kooman
Modified: 2008-02-12 09:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 09:15:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description François Kooman 2007-05-05 16:23:14 EDT
Description of problem:

NetworkManager should be able to connect to wired and wireless network at the
same time (using different metric in route table)

How reproducible:

Use NetworkManager with both wired and wireless connection, unwanted behavior
when switching to wireless.

Steps to Reproduce:
1. Start in situation where you are connected to wired network
2. Try to connect to wireless network
3. NetworkManager disables wired network! 
4. Asks for key
5. Connects to wireless network
6. If this fails switch back to wired

Expected results:
1. Start in situation where you are connected to wired network
2. Try to connect to wireless network
4. Asks for key
5. Connects to wireless network with higher metric value in route table
6. If this fails, do nothing

Additional info:

When connected to wireless and wired network wired network is preferred. When
you unplug wired immediate switch to wireless.

The problem now is that when you try to connect to wireless network the wired
connection is disabled before the wireless connection is brought up (unwanted).
They should be both active, or only disconnect wired when the connection to the
wireless network is successful.
Comment 1 Matt Bernstein 2007-10-24 12:14:34 EDT
I would prefer to see this done at layer 2, so that your SSH terminals don't
die. Perhaps this could be achieved with a bridge device, but this is quite hard
to pull off given the dangers of network loops. Maybe wait for RSTP to hit the
Linux kernel?
Comment 2 Dan Williams 2008-02-12 09:15:21 EST

*** This bug has been marked as a duplicate of 178276 ***

Note You need to log in before you can comment on or make changes to this bug.