Bug 239202 - "root filesystem not large enough" checked too late
Summary: "root filesystem not large enough" checked too late
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: Fedora7LiveCD
TreeView+ depends on / blocked
 
Reported: 2007-05-06 01:29 UTC by Petr Machata
Modified: 2015-05-05 01:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-07 18:47:06 UTC


Attachments (Terms of Use)

Description Petr Machata 2007-05-06 01:29:56 UTC
Description of problem:
During the installation from live CD, following message is reported:
 """The root filesystem you created is not large enough for this live image."""

That makes sense, as the machine that I'm installing on has very limited
resources, but:
 a) I'd like to know what is "large enough".
 b) I'd like to know that it isn't large enough before there is too late to
change the setting.  By the time this gets reported, it's no longer possible to
get back to the partitioning screen, presumably because I decided to use the
swap immediately (only 180MB of memory on this box).

Version-Release number of selected component (if applicable):
FC7-test4 Live

How reproducible:
Always.

Steps to Reproduce:
1. Partition the disk in such a way that not enough space is available on /.
(This was ~900MB in my case.)
2. Have too little memory, so that swap is immediately turned on (maybe this
step isn't necessary).
3. Continue installation process.  The message appears after the root password
screen.
  
Actual results:
As described.

Expected results:
As described.

Additional info:
No.

Comment 1 Jeremy Katz 2007-05-07 18:47:06 UTC
Without large invasive changes to anaconda, this was the only place we could
really slot the check in.  And yes, you only can't go back due to early swap.



Comment 2 Petr Machata 2007-05-07 19:08:48 UTC
Ok.  Any chance of at least mentioning required "large enough" size in the dialog?

Comment 3 Jeremy Katz 2007-05-07 19:16:22 UTC
(In reply to comment #2)
> Ok.  Any chance of at least mentioning required "large enough" size in the dialog?

That would break every translation, which isn't really appropriate.  We've
already been bad enough about late string changes.


Note You need to log in before you can comment on or make changes to this bug.