This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 239210 - SELinux error when trying to create virtual machine
SELinux error when trying to create virtual machine
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Berrange
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-06 01:22 EDT by Justin Mahoney
Modified: 2008-01-10 23:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 23:08:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of error message from virt-manager (43.85 KB, image/png)
2007-05-06 01:22 EDT, Justin Mahoney
no flags Details

  None (edit)
Description Justin Mahoney 2007-05-06 01:22:38 EDT
Description of problem:

virt-manager 0.4.0, Fedora 7 Test 4, Xen kernel
'Creating a new virtual system'
System Name: openSUSE (10.3 Alpha 3 DVD in drive)
Fully Virtualized
CD-ROM or DVD: SU103Alp.001 (DVD-ROM image name)
OS Type: Linux
OS Variant: Generic 2.6.x kernel
Simple File: /var/lib/xen/images/openSUSE
10 GB, entirely allocated
Shared physical device, xenbr0
512 Max Memory, 512 Startup Memory (2.00 GB in host)
1 VCPU

After I click 'Finish', I get:
'Unable to complete install: 'virDomainCreateLinux() failed POST operation
failed: (xend.err 'Device 0 (vif) could not be connected. Hotplug scripts not
working.')'

See attached PNG.

Version-Release number of selected component (if applicable):

0.4.0
Comment 1 Justin Mahoney 2007-05-06 01:22:39 EDT
Created attachment 154220 [details]
screenshot of error message from virt-manager
Comment 2 Justin Mahoney 2007-05-06 16:41:18 EDT
I reinstalled with default kerrnel, and set SELinux to 'Permissive.' Still got
the same error, so it looks like it's not SELinux related. I assumed it was
SELinux related because of all the SELinux alerts I was getting.
Comment 3 Andrew Pannell 2007-06-22 00:06:08 EDT
I have also had this problem installing F7. I have also tried both ethernet
options in the virt-manager.
Host:Fedora (2.6.20-2925.11.fc7xen)
Guest URL :
http://download.fedora.redhat.com/pub/fedora/linux/releases/7/Fedora/i386/os/
Install Location: /var/lib/xen/images/
Virtual Network : Default (Though I have had the same problem using Shared
Physical Device : eth0)
VM Max = VM Startup = 256MB
VPU = 1
Comment 4 Andrew Pannell 2007-06-22 23:14:51 EDT
I have been able to get past this there are a couple of threads that talk about
this particular problem please refer to them for further details.

I eventually installed sysfsutils
(http://lists.xensource.com/archives/html/xen-users/2005-11/msg00127.html)

This did not seem to work however it might be required anyway.

what did work was doing steps 2 and 4 of this post
(http://lists.xensource.com/archives/html/xen-users/2005-10/msg00152.html)
2. /etc/xen/scripts/network start
4 /etc/xen/scripts/vif-bridge up domain=RHL vif=vif1.0 bridge=xen-br0
Comment 5 Andrew Pannell 2007-06-25 20:10:08 EDT
Further to the above. 

The previous efforts allowed the completion of the image creation but when it
came to installing the client OS the system failed as it could not initialise
the ipv6 ethernet stack. It didn't matter which ipv6 option you chose or even if
you turned it off in the install options.

After trawling through the logs on the host OS the new errors reported were
xen-hotplug.log mkdir: cannot create directory `/var/run/xen-hotplug':
Permission denied

Given that I had problems reported by the selinux trouble shooter in creating
this log file I assumed that there is a problem with the selinux permissions for
virtulization and so set selinux to to disable and then ran 'fixfiles relabel'.
After starting the entire process again I was able to complete the intallation.

To me this is defiantly an issue with selinux not allowing the correct
establishment of the networking scripts.
Comment 6 Red Hat Bugzilla 2007-07-24 22:11:12 EDT
change QA contact
Comment 7 Daniel Berrange 2007-09-27 17:16:16 EDT
If you are still encountering problems with this could you provide 

 /root/.virt-manager/virt-manager.log

From just after an attempt to create a VM, along with the output of 'ifconfig
-a', 'brctl show' and /var/log/xen/xend.log
Comment 8 Daniel Berrange 2008-01-10 23:08:51 EST
Closing since no further reports of problems provided by submitter. Please
re-open if it still occurrs

Note You need to log in before you can comment on or make changes to this bug.