Bug 239221 - Audio playback only via headphone socket
Audio playback only via headphone socket
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-06 07:16 EDT by Duncan Innes
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 04:57:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Soundcard log (46.40 KB, text/plain)
2007-05-09 07:52 EDT, Duncan Innes
no flags Details

  None (edit)
Description Duncan Innes 2007-05-06 07:16:52 EDT
Description of problem: Audio playback is only via headphone socket.  Very
occasionally the internal speakers will work, but audio always available via the
headphone socket.


Version-Release number of selected component (if applicable):


How reproducible: Sound is always available via headphones and I've only managed
to get sound from the internal speakers once or twice.


Steps to Reproduce:
1. Play video via xine
2. 
3.
  
Actual results: Audio available via headphones, but not normally via internal
speakers


Expected results: Sound should come from internal speakers when headphones not
plugged in


Additional info: Thinkpad T40 with clean install of Fedora 7 test 3.  Then
upgraded to test 4 via yum.  I initially suspected that I had managed to leave
the internal speakers disconnected by mistake when I had taken the laptop apart,
but somehow got audio playback from the speakers a few days ago.  Since then
I've been trying to track down what might have changed.  The audio was perfectly
smooth, so not indicative of a faulty connection.  When the audio did work, I
was playing a WMV file via xine and not expecting audio playback.  The audio did
work perfectly on this occasion however.  I then tried other audio playback
methods (Rhythmbox, Mplayer etc) but audio only via headphones with these.  Once
I'd tried the other methods, the audio playback of the file stopped working
under xine.  This is what prompted me to think it might be a software issue.

I'm trying to track down what might be going on, but require help in excluding
various issues as I'm not well versed in the way audio works under Linux.

I have submitted hardware information via the firstboot and am trying to locate
my specific entry.

I'll attach anything extra I find as soon as I find it.

If this is worth tracking down, please let me know.  The reverse is also true -
I don't want to waste effort on a wild goose chase that doesn't matter.
Comment 1 Duncan Innes 2007-05-06 08:03:10 EDT
Smolt UUID is: 1f038671-5f58-4601-ab0d-ad085f18c43a
Comment 2 Martin Stransky 2007-05-09 07:46:41 EDT
Please run system-config-soundcard, create a log (/root/scsconfig.log) on the
"System" page and attach it here.
Comment 3 Duncan Innes 2007-05-09 07:52:59 EDT
Created attachment 154388 [details]
Soundcard log
Comment 4 Martin Stransky 2007-05-09 08:34:56 EDT
Hm, I have no ide where could be the problem. Log looks sane and I don't see any
problem there.
Comment 5 Martin Stransky 2007-05-09 08:35:55 EDT
I think you should report it to ALSA project (www.alsa-project.org), they're
authors of linux sound system.
Comment 6 Duncan Innes 2007-05-09 09:37:34 EDT
No problem.  Like I said - it wasn't something I planned to report initially due
to my having tinkered around inside a while ago.  Can't really remember if
on-board speakers worked after that or not - it's not a priority of mine.

Was just surprised to hear sound out of them last week.

I'll report to the ALSA mob.

Thanks

D
Comment 7 Martin Stransky 2007-05-16 04:57:59 EDT
okay, closing as can't fix.

Note You need to log in before you can comment on or make changes to this bug.