Bug 239246 - Some additions
Summary: Some additions
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: filesystem   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F8Target
TreeView+ depends on / blocked
 
Reported: 2007-05-06 21:31 UTC by Matthias Clasen
Modified: 2015-03-05 01:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-24 14:37:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthias Clasen 2007-05-06 21:31:34 UTC
There are a number of widely used directories with no clear natural owner,
that should probably go into filesystem (or in the future, in a
filesystem-desktop subpackage):

/usr/share/themes - natural companion to /usr/share/icons, which is already there
/usr/share/backgrounds - for this one, we could alternatively declare  
     desktop-backgrounds-basic to be the official owner...
/usr/share/gtk-doc/html - since /usr/share/gtk-doc is already there, and the
     html subdirectory is the actually problematic one.  Although I must admit
     that I'd be just as happy to have these be owned by gtk-doc

Comment 1 Nicolas Mailhot 2007-05-14 15:03:15 UTC
/etc/fonts/conf.d needs to join them.

Our font packaging guidelines ask for font packages not to depend on fontconfig.
However several packages drop fontconfig rules in /etc/fonts/conf.d (the rules
are interpreted if fontconfig is present. If not the main "feature" of font
packages, the font files themselves, is still available for use, and the rule
files harm no one)

Currently that means /etc/fonts/conf.d can be used without a package owning it.
To respect the "directory ownership" guideline this directory should be
transferred from fontconfig to a neutral filesystem package font packages can
depend on (without forcing install of fontconfig binaries)

Comment 2 Phil Knirsch 2007-05-24 14:37:08 UTC
I agree with /usr/share/themes and /etc/fonts/conf.d being part of filesystems,
changes have already been put it.

For /usr/share/backgrounds and /usr/share/gtk-doc/html i'd rather seem those
being owned by the packages you mentioned above.

Fixes will be in next filesystem build.

Thanks,

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.