This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 239252 - 256 color support broken
256 color support broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-06 21:54 EDT by Leo
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 05:40:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
emacs-256color (147.39 KB, image/png)
2007-05-06 21:54 EDT, Leo
no flags Details

  None (edit)
Description Leo 2007-05-06 21:54:58 EDT
Description of problem:
I looks like the support of 256 color in xterm is broken. I use Emacs to test
this. Although it list 256 color names, only the first 7 have colors. Please see
the attached screenshot.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Leo 2007-05-06 21:54:58 EDT
Created attachment 154237 [details]
emacs-256color
Comment 2 Miroslav Lichvar 2007-05-07 04:05:50 EDT
Works for me. Is TERM variable set to xterm-256color ?
Comment 3 Leo 2007-05-07 04:48:52 EDT
It turns out it is a bug in Emacs. I updated to the latest source and it is now
working properly.

Please close this bug.

Note You need to log in before you can comment on or make changes to this bug.