Bug 239309 - koji /usr/bin/fedora-packager-setup.sh doesn't handle certs getting updated
Summary: koji /usr/bin/fedora-packager-setup.sh doesn't handle certs getting updated
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: koji   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-07 14:39 UTC by Ray Strode [halfline]
Modified: 2013-01-10 01:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 22:02:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ray Strode [halfline] 2007-05-07 14:39:59 UTC
Recently I discovered my ~/.fedora.crt was expired.

I got a new one from https://admin.fedoraproject.org/accounts/gen-cert.cgi and
dropped it in place, reran /usr/bin/fedora-packager-setup.sh and the resulting
pkcs12 file was from the old cert!

It turns out the cert gets copied to ~/.koji, so changing ~/.fedora.crt and
rerunning the script doesn't work (without manually removing the copy in ~/.koji)

Comment 1 Jesse Keating 2007-05-22 22:02:58 UTC
We've fixed this problem.


Note You need to log in before you can comment on or make changes to this bug.