Bug 239330 - cpu_weight does not work
Summary: cpu_weight does not work
Status: CLOSED DUPLICATE of bug 233287
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Xen Maintainance List
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-07 16:17 UTC by Dirk Nehring
Modified: 2008-02-27 02:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 02:39:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
XenSource 835 None None None Never

Description Dirk Nehring 2007-05-07 16:17:17 UTC
Description of problem:
cpu_weight does not work in config file

Version-Release number of selected component (if applicable):
xen-3.0.3-25.0.3.el5

How reproducible:
cpu_weight = '128'

into your config, restart the guest.

xm sched-credit -d <guest>
{'cap': 0, 'weight': 256}

But I can set the weight by hand:
xm sched-credit -d <guest> -w 128
root@cda-gw:~# xm sched-credit -d <guest>
{'cap': 0, 'weight': 128}

  
Additional info:

Comment 1 Chris Lalancette 2008-02-27 02:39:32 UTC

*** This bug has been marked as a duplicate of 233287 ***


Note You need to log in before you can comment on or make changes to this bug.