Bug 239335 - s3 suspend regression in Rawhide
s3 suspend regression in Rawhide
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-07 13:10 EDT by Casper Gasper
Modified: 2008-05-06 21:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 21:42:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lsmod (3.54 KB, text/plain)
2007-05-07 13:10 EDT, Casper Gasper
no flags Details
lspci (2.08 KB, text/plain)
2007-05-07 13:11 EDT, Casper Gasper
no flags Details
lspci -n (750 bytes, text/plain)
2007-05-07 13:12 EDT, Casper Gasper
no flags Details

  None (edit)
Description Casper Gasper 2007-05-07 13:10:26 EDT
Description of problem:

Suspend-to-ram used to work on my Lenovo 3000 N100 but now doesn't.  The machine
goes to sleep fine, but doesn't wake up; it whirrs the fans when it resumes but
that's it (it's not just the screen staying blank, it doesn't respond to pings.)

Suspend does work with the vanilla 2.6.21.1 kernel

Version-Release number of selected component (if applicable):
kernel 2.6.21-1.3116
kernel 2.6.20-1.3104

How reproducible:
Always



Steps to Reproduce:
1. run pm-suspend
2. try to wake up laptop

  
Actual results:
Fails to wake up.

Expected results:


Additional info:
I did read in a bug report that iwlwifi could be causing suspend problems --
I've tried modprobe -r iwlwifi, but it still fails to resume.
Comment 1 Casper Gasper 2007-05-07 13:10:26 EDT
Created attachment 154282 [details]
lsmod
Comment 2 Casper Gasper 2007-05-07 13:11:28 EDT
Created attachment 154283 [details]
lspci
Comment 3 Casper Gasper 2007-05-07 13:12:15 EDT
Created attachment 154284 [details]
lspci -n
Comment 4 Will Woods 2007-05-07 13:13:33 EDT
What version of hal are you using? If 0.5.9-6, could you try downgrading to 0.5.9-5?
Comment 5 Casper Gasper 2007-05-10 12:01:44 EDT
It is 0.5.9-6, I downgraded to hal-0.5.9-5 and it's still broken in exactly the
same way.
Comment 6 Richard Hughes 2007-05-24 06:44:44 EDT
Can you try the new mini-site I've created:
http://people.freedesktop.org/~hughsient/quirk/ - thanks!
Comment 7 Casper Gasper 2007-06-02 17:56:06 EDT
Thanks Richard, I did have a look at your site and went through the suggestions
without much luck.  But it looks like it's fixed as of 2.6.21-1.3199.fc8 (it
also BTW gives me working sound -- hurrah!).  

I notice this kernel doesn't have the iwl3945 module, maybe that was the
problem?  Although I had tried rmmodding it with no success.  
 
Comment 8 Richard Hughes 2007-06-07 10:12:34 EDT
The F7 gold kernel is busted. I'm yelling at people to get this fixed as an
update ASAP.
Comment 9 Bug Zapper 2008-04-03 20:34:49 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 10 Bug Zapper 2008-05-06 21:42:05 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

Note You need to log in before you can comment on or make changes to this bug.