Bug 239362 - Character encoding roblem with displaying date information
Character encoding roblem with displaying date information
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
rawhide
All All
medium Severity low
: ---
: ---
Assigned To: John Dennis
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-07 16:51 EDT by Alexander Shopov
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-30 12:56:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the dialog with problem (257.75 KB, image/png)
2007-05-07 16:51 EDT, Alexander Shopov
no flags Details
This is the description of what is OK and what not. (71.63 KB, image/png)
2007-06-27 02:57 EDT, Alexander Shopov
no flags Details

  None (edit)
Description Alexander Shopov 2007-05-07 16:51:44 EDT
Description of problem:
When used in Bulgarian UTF-8 locale setroubleshoot shows date informaion wrongly
recoded. I will attach a screenshot demonstrating the problem.

Version-Release number of selected component (if applicable):
1.9.4


How reproducible:
Always

Steps to Reproduce:
1. Use bg_BG.UTF-8 locale
2. Open any event reportd by setroubleshoot
3. Voila
  
Actual results:
Info that is recoded in some wrong encoding

Expected results:
Proper dates in cyrillic

Additional info:
Will provide on request
Comment 1 Alexander Shopov 2007-05-07 16:51:45 EDT
Created attachment 154297 [details]
Screenshot of the dialog with problem
Comment 2 John Dennis 2007-06-26 16:59:40 EDT
I would like to narrow the problem down. In your screenshot you've very nicely
called out the problem. 

The same date information is shown in the "browser list" at the top of the
screen in the date column. The only difference is the string is rendered by two
differnt libraries.

Is the date rendered in the date column at the top correct?
Comment 3 Alexander Shopov 2007-06-27 02:53:21 EDT
The date in the "Date" column in the list pane of the setroubleshoot browser is OK.

I will add a screen shot with what is OK and what is garbled.


Comment 4 Alexander Shopov 2007-06-27 02:57:43 EDT
Created attachment 157983 [details]
This is the description of what is OK and what not.
Comment 5 John Dennis 2007-06-30 12:56:18 EDT
Thank you for taking the time reporting this and your gracious help in preparing
the screenshots, it helped me.

Fixed. Should appear in the next release which I'm anticipating as 1.9.8

From the changelog:

Actually the entire detail view (rendered as HTML) had the wrong
encoding, since we did not explicitly set it to UTF-8 it defaulted to 
the default HTML charset ISO-8859-1. We now include an HTML header in
the HTML document and set the meta http-equiv="Content-Type" in the
HTML document header to specify the UTF-8 charset.
Comment 6 Alexander Shopov 2007-07-04 07:33:58 EDT
Thanx John for the quick fix.

Kind regards:
al_shopov

Note You need to log in before you can comment on or make changes to this bug.