Bug 239364 - hal notices 26 seconds after /proc that my AC cable has been (un-)plugged
hal notices 26 seconds after /proc that my AC cable has been (un-)plugged
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-07 16:56 EDT by Zack Cerza
Modified: 2013-03-05 22:50 EST (History)
2 users (show)

See Also:
Fixed In Version: F9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 11:17:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zack Cerza 2007-05-07 16:56:00 EDT
Description of problem:
hal takes 26 seconds to realize that my AC cable has been unplugged, even though
/proc takes less than a second. This happens even when I've not suspended
previously.

# cat /proc/acpi/ac_adapter/AC/state; date
state:                   on-line
Mon May  7 14:23:04 EDT 2007
# cat /proc/acpi/ac_adapter/AC/state; date
state:                   off-line
Mon May  7 14:23:04 EDT 2007
# lshal -m                                

Start monitoring devicelist:
-------------------------------------------------
14:23:30.492: acpi_AC property ac_adapter.present = false
14:23:30.503: acpi_BAT0 property battery.remaining_time = 14105 (0x3719) (new)
14:23:30.554: acpi_BAT0 property battery.charge_level.rate = 16630 (0x40f6)
14:23:30.556: acpi_BAT0 property battery.charge_level.current = 65160 (0xfe88)
14:23:30.559: acpi_BAT0 property battery.voltage.current = 16084 (0x3ed4)
14:23:30.561: acpi_BAT0 property battery.reporting.rate = 16630 (0x40f6)
14:23:30.564: acpi_BAT0 property battery.reporting.current = 65160 (0xfe88)
14:23:30.566: acpi_BAT0 property battery.rechargeable.is_discharging = true
14:23:30.691: computer property power_management.is_powersave_set = true

Version-Release number of selected component (if applicable):
hal-0.5.9-6.fc7.i386
kernel-2.6.21-1.3125.fc7.i686
Comment 1 Zack Cerza 2007-05-11 17:35:39 EDT
Still happening with kernel-2.6.21-1.3141.fc7. Also, every other lid open/close
sequence seems to be ignored. I'll suspend via lid close, open it to resume,
then later, I close the lid and nothing happens. Nothing in
/var/log/pm-suspend.log either. The subsequent lid close will cause the laptop
to actually suspend.
Comment 2 Jan Hutař 2007-10-20 19:04:09 EDT
Hello,
this works for me as expected on Thinkpad T61 with:

hal-0.5.10-1.fc8
kernel-2.6.23.1-23.fc8
Comment 3 Matthias Clasen 2007-10-20 21:38:00 EDT
Zack, are you still seeing this ?
Comment 4 Zack Cerza 2007-10-22 11:24:35 EDT
Not seeing it anymore in F7, so closing.
Comment 5 Zack Cerza 2007-11-15 13:05:32 EST
Seeing this in F8 now.

hal-0.5.10-1.fc8.i386
kernel-2.6.23.1-42.fc8.i686
Comment 6 Zack Cerza 2007-11-15 13:06:51 EST
Oh. Delays also happen on plug-in, now.
Comment 7 Jan Hutař 2007-11-19 08:30:07 EST
I can not see it in F8 on a T61 x86_64. "lshal -m" shows the message after +- 
1s I remove/plug-in a power cable.

hal-0.5.10-1.fc8
kernel-2.6.23.1-42.fc8
Comment 8 Richard Hughes 2008-05-30 07:29:12 EDT
With F9, all the power_supply breakage should have settled down. is this issue
now fixed in F9?
Comment 9 Zack Cerza 2008-05-30 11:17:23 EDT
Seems to be fixed, yes. I'll reopen if I see it later.

Note You need to log in before you can comment on or make changes to this bug.