Bug 239374 - RFE: add virtual Provides: emacs(bin) to emacs and emacs-nox packages
Summary: RFE: add virtual Provides: emacs(bin) to emacs and emacs-nox packages
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Coldwell
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-07 22:21 UTC by Jonathan Underwood
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: 22.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 01:27:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Underwood 2007-05-07 22:21:21 UTC
Description of problem:
XEmacs packages xemacs and xemacs-nox both have a Provides: xemacs(bin) so that
when packaging an add-on package which does not care about Xorg support you can
simply have a Requires: xemacs(bin).

No such facility currently exists for emacs and emacs-nox. An approximation to
this is to have Requires: emacs-common in add-on packages, since emacs and
emacs-nox both Require:emacs-common. But, then you could install your add-on
package, have it pull in emacs-common, but that wouldn't pull in emacs or
emacs-nox. User scratches head.

Comment 1 Ville Skyttä 2007-05-07 22:52:06 UTC
RFE seconded.

But I should also mention that I'm not particularly proud of xemacs(bin) as the
name for the Provides, the "bin" isn't really very descriptive.  If someone can
come up with something significantly better, I'm open to changing that in the
XEmacs packages too.  Perhaps emacs(ui), emacs(main), or emacs(impl), or
emacs(your_suggestion_here)?  I can live with "bin" though.

Also, if the Provides are added to the main emacs and emacs-nox packages, a
dependency on it can be added to emacs-common like "Requires: emacs(bin) =
%{version}-%{release}" which makes sure emacs-common won't be installed without
an actual Emacs editor.  I haven't done that in the xemacs-common package; not
sure why - I'll look into it.

Comment 2 Jonathan Underwood 2007-05-07 23:35:38 UTC
Possible virtual provides names I can think of (none of which I feel any more
passionate about really):

emacs(editor)
emacs(frontend)
emacs(program)

or if we don't need ()s'
emacs-editor
emacs-frontend
emacs-program

Comment 3 Jonathan Underwood 2007-06-01 23:46:47 UTC
Hi Chip, Ville - it would be nice if we could resolve this one so that we can
finalize the packaging guidelines for emacsen add on packages.

Comment 4 Chip Coldwell 2007-08-14 15:58:53 UTC
Added in 22.1-2.


Comment 5 Jonathan Underwood 2007-11-26 01:27:41 UTC
This is resolved, closing bug.


Note You need to log in before you can comment on or make changes to this bug.