Bug 239404 - e1000 driver doesn't configure and xen won't create virtual machines
e1000 driver doesn't configure and xen won't create virtual machines
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-08 04:19 EDT by Steven Dake
Modified: 2016-04-26 10:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-13 10:23:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Dake 2007-05-08 04:19:13 EDT
Description of problem:
xen doesn't create virtual machines on a T60 laptop unless a network cable is
plugged into the network port and attached to a switch/hub.

Version-Release number of selected component (if applicable):
rhel5 gold +
xen-3.0.3-26.el5
kernel-xen-2.6.18-8.1.3.el5

How reproducible:
100%

Steps to Reproduce:
1. Boot Thinkpad T60 laptop ordered from Red Hat internal sourcing as of May
2007 without network cable plugged in with E1000 network port configured to
static IP addressing
2. xm create -c rhel5n1 (where rhel5n1 is a working virtual machine)
  
Actual results:
xm create command reports error and doesn't create a virtual machine

Expected results:
xm create should create a virtual machine 

Additional info:
I noticed that if I later plug in the e1000 network cable, xm create works. 
Then if I unplug the network cable, xm create continues to work properly.

It also appears that ifcfg-eth1 is not properly configuring the E1000 network
interface address during startup - but only setting it properly when the network
cable is plugged in.  Once the cable has been plugged in and xend restarted, the
system works properly.

This makes using xen difficult on the T60 requiring plugging the t60 laptop into
a network port at some point before using xen.

Reference bz 239201 which indicates the ipw3945 wireless card does not work at
all with the xen kernel without changing start orders of init scripts.  Note
during this bug report I reverted all start orders to those start orders shipped
with RHEL5.  The ipw3945 wireless adapter can also not be used to boot the xen
machines as a result.
Comment 2 Daniel Berrange 2008-07-11 09:10:31 EDT
Please provide more information if this is still a problem,


 - /var/log/messages
 - /var/log/dmesg
 - ifconfig -a
 - lspci -vv
Comment 3 Rik van Riel 2009-01-09 13:39:11 EST
This looks like a userspace issue, either with userspace xen or virt-manager and friends.
Comment 6 Rik van Riel 2009-01-13 10:23:38 EST
Apparently this was fixed by RHEL 5.2.

Note You need to log in before you can comment on or make changes to this bug.