Bug 239407 - usb-storage changes device order post installation
usb-storage changes device order post installation
Status: CLOSED DUPLICATE of bug 248619
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.5
All Linux
urgent Severity high
: ---
: ---
Assigned To: David Lehman
:
Depends On:
Blocks: 246627 253671 351901
  Show dependency treegraph
 
Reported: 2007-05-08 05:19 EDT by Bryn M. Reeves
Modified: 2012-05-19 19:50 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 12:42:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryn M. Reeves 2007-05-08 05:19:55 EDT
Description of problem:
When carrying out an installation using a usb-storage device (for e.g. USB
floppy) the device node assigned to the device changes between the installation
environment and the installed system.

E.g.:

During installation: HDD -> /dev/sda, FDD -> /dev/sdb
After installation: HDD -> /dev/sdb, FDD -> /dev/sda

This is related to bug 234815.

Version-Release number of selected component (if applicable):
10.1.1.46

How reproducible:
100%

Steps to Reproduce:
1. Carry out an installation with a usb-storage device attached, e.g. kickstart
from USB floppy
2. Check device node assignment during installation
3. Check device node assignment after installation
  
Actual results:
Device nodes are exchanged between the installer and installed environments.

Expected results:
Device nodes remain unchanged between the installer and installed environments.

Additional info:
Comment 1 RHEL Product and Program Management 2007-05-08 16:19:22 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Red Hat Bugzilla 2007-06-11 23:51:53 EDT
requested by Jams Antill
Comment 6 David Cantrell 2007-08-21 17:23:36 EDT
Moving to 4.7.
Comment 8 David Cantrell 2007-08-22 10:29:20 EDT
Yes, lack of engineering capacity.  The device enumeration process works much
better in RHEL5 than 4 and I don't view this as that critical of a problem. 
Worst case, we can document it in the release notes and make sure customers are
aware of what can potentially happen when USB devices are connected during
installation.
Comment 12 David Lehman 2007-12-10 12:41:42 EST
See comment #8. The amount of work this would require, combined with the fact
that  this isn't really breaking anything, makes this a poor candidate for an
update so late in the RHEL4 product life cycle. This does seem like a good
candidate for a release note.
Comment 13 RHEL Product and Program Management 2007-12-10 12:42:52 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 
Comment 15 David Lehman 2007-12-19 14:51:28 EST

*** This bug has been marked as a duplicate of 248619 ***

Note You need to log in before you can comment on or make changes to this bug.