Bug 239426 - wp_tray is using /usr/share/backgrounds/images
wp_tray is using /usr/share/backgrounds/images
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wp_tray (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-08 08:05 EDT by Sebastian Vahl
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.5.3-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-16 09:24:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2007-05-08 08:05:18 EDT
Description of problem: Since the update to 0.5.3 (AFAIR) wp_tray is also using
/usr/share/backgrounds/images. I don't have this directory enabled in the settings.


Version-Release number of selected component (if applicable):
wp_tray-0.5.3-2.fc7

How reproducible:


Steps to Reproduce:
1. wait some time or manually use "Forward" to change the wallpaper
2.
3.
  
Actual results: 
Some wallpapers are used from /usr/share/backgrounds/images

Expected results:
Since this directory is not configured in settings no wallpapers from there
should be used.


Additional info:  cat ~/.gconf/apps/wp_tray/%gconf.xml


<?xml version="1.0"?>
<gconf>
        <entry name="b_follow_links" mtime="1178044064" type="bool" value="false">
        </entry>
        <entry name="b_img_check" mtime="1178044064" type="bool" value="true">
        </entry>
        <entry name="b_wp_logon" mtime="1178044064" type="bool" value="true">
        </entry>
        <entry name="b_timeout" mtime="1178044064" type="bool" value="true">
        </entry>
        <entry name="n_timeout" mtime="1178044064" type="int" value="15">
        </entry>
        <entry name="dir_list" mtime="1178044064" type="list" ltype="string">
                <li type="string">
                        <stringvalue>/daten/install/Wallpaper/Abtract</stringvalue>
                </li>
                <li type="string">
                        <stringvalue>/daten/install/Wallpaper/Fedora</stringvalue>
                </li>
                <li type="string">
                        <stringvalue>/daten/install/Wallpaper/Nature</stringvalue>
                </li>
                <li type="string">
                       
<stringvalue>/daten/install/Wallpaper/Political</stringvalue>
                </li>
        </entry>
</gconf>
Comment 1 Denis Leroy 2007-05-08 16:35:26 EDT
Right, this is actually not a bug. It seems to be a feature added to 0.5.3.
Essentially when it sets a random background, it will always add the wallpapers
list from the standard Gnome Desktop Background tool (from the file
~/.gnome2/backgrounds.xml).

Though i admit this is a pretty annoying feature. I'll provide a patch to make
this optional from the Preferences.
Comment 2 Denis Leroy 2007-05-08 18:03:41 EDT
Fixed, added a patch to make the 0.5.3 "feature" optional in the Preferences
dialog. SRPM is available here :

http://www.poolshark.org/src/wp_tray-0.5.3-3.fc7.src.rpm

Please let me know if it fixes your problem.
Comment 3 Sebastian Vahl 2007-05-09 04:44:53 EDT
(In reply to comment #2)
> Fixed, added a patch to make the 0.5.3 "feature" optional in the Preferences
> dialog. SRPM is available here :
> 
> http://www.poolshark.org/src/wp_tray-0.5.3-3.fc7.src.rpm
> 
> Please let me know if it fixes your problem.

It seems to work. I've set "Rotate Interval" to 1 minute and waited an hour.
I've also used "Forward" several times. No wallpaper from /usr/share/backgrounds
were used.

Comment 4 Fedora Update System 2007-06-16 09:24:29 EDT
wp_tray-0.5.3-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.