Bug 239440 - TurboGears: OverflowError on "tg-admin quickstart"
TurboGears: OverflowError on "tg-admin quickstart"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: TurboGears (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-08 10:03 EDT by Mads Kiilerich
Modified: 2016-09-19 22:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-14 10:32:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2007-05-08 10:03:16 EDT
This is NOT a bug a in python bug a bug in python-ruledispatch or TurboGears,
found in extras-development, but not available in the Bugzilla Component list...


Description of problem:
"tg-admin quickstart" gives "OverflowError: long int too large to convert to int" 


Version-Release number of selected component (if applicable):
TurboGears-1.0.1-2.fc7
python-ruledispatch-0.5a0-0.4.svnr2115.fc7

How reproducible:
very

Steps to Reproduce:
1. tg-admin quickstart      (step 1 in tutorial)
  
Actual results:
...
  File "/usr/lib/python2.5/site-packages/dispatch/strategy.py", line 541, in __new__
    self = int.__new__(cls,id(ob))
OverflowError: long int too large to convert to int


Expected results:
Something better...

Additional info:
Seems to be same as
http://www.mail-archive.com/turbogears-trunk@googlegroups.com/msg02703.html

A serious bug in a not-so-strategic package...
Comment 1 Mads Kiilerich 2007-05-08 12:45:04 EDT
According to elvelind on #turbogears it is because TurboGears 1.1 doesn't
support Python 2.5.

As it is now the package isn't usable at all, so even though a version-upgrade
(to 1.0.2.2) is risky it can only get better.
Comment 2 Mads Kiilerich 2007-05-08 17:59:49 EDT
That should be "TurboGears 1.0.1 doesn't support Python 2.5"

And sorry for reporting this on the wrong product, but I wasn't aware that
"Fedora Extras" still should be used for Fedora 7.
Comment 3 Luke Macken 2007-05-08 18:08:57 EDT
I have TurboGears 1.0.2.2 (along with it's deps) all packaged and ready to go
for F7, it's just waiting on a new dependency python-decoratortools (Bug
#238932).  So I'm hoping that I'll have the TurboGears stack in working order
for rawhide at some point this week.
Comment 4 Luke Macken 2007-05-14 10:32:39 EDT
I released TurboGears-1.0.2.2-2.fc7 on friday, which should resolve this issue.

Note You need to log in before you can comment on or make changes to this bug.