Bug 239502 - adminserver: autotools, FHS, and many bug fixes
adminserver: autotools, FHS, and many bug fixes
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Admin (Show other bugs)
1.0.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
Depends On:
Blocks: 152373 240316 FDS1.1.0
  Show dependency treegraph
 
Reported: 2007-05-08 19:21 EDT by Rich Megginson
Modified: 2015-12-07 11:58 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:58:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cvs commit log (41.11 KB, text/plain)
2007-05-08 20:49 EDT, Rich Megginson
no flags Details
cvs commit log (8.37 KB, text/plain)
2007-05-11 15:48 EDT, Rich Megginson
no flags Details
cvs commit log (2.16 KB, text/plain)
2007-05-14 20:31 EDT, Rich Megginson
no flags Details
cvs commit log (2.05 KB, text/plain)
2007-05-15 12:47 EDT, Rich Megginson
no flags Details
cvs commit log (2.22 KB, text/plain)
2007-05-15 19:00 EDT, Rich Megginson
no flags Details
cvs commit log (2.59 KB, text/plain)
2007-05-21 11:55 EDT, Rich Megginson
no flags Details

  None (edit)
Description Rich Megginson 2007-05-08 19:21:00 EDT
adminserver needs to be autotool-ized, FHS-ized, and probably has many
outstanding bugs.
Comment 1 Rich Megginson 2007-05-08 20:49:46 EDT
Created attachment 154368 [details]
cvs commit log
Comment 2 Rich Megginson 2007-05-11 15:48:35 EDT
Created attachment 154565 [details]
cvs commit log

Fix Description: Many more changes to make admin server more FHS friendly
Allow all hardcoded paths to writable directories to be overridden by
environment variables
Integrate mod_admserv and mod_restartd
Allow Admin Server to use Fortitude or standalone mod_nss
Better httpd detection and support
Comment 3 Rich Megginson 2007-05-14 20:31:58 EDT
Created attachment 154698 [details]
cvs commit log

Fix Description: 1) Added the admin.inf file, which contains information about
the brand, product name, vendor, build number, and other information.  This
gets
put in an inf/ subdir of the ds datadir.  The update program reads this
information and updates the info in the ISIE and SIE entries.  This allows us
to remove
some of the branded code.
2) We need to set the cgisock path for mod_cgid and mod_restartd.
3) The update program needs to modify some http style conf file parameters. 
The config CGI program already does this.  I modified the config CGI program so
that it could be run from the command line and modify the parameters that the
update program needs.
4) Removed lots of dead code from ux-update.cc.  The way it works now is that
the config files are generated at build time, not at install time, so a lot of
that logic could be removed.  We still need to update a few parameters at
install time - see 3 above.
5) User can specify configdir, securitydir, logdir, and piddir in the setup.inf

file at install time, or can specify environment variables for those, or it
will just use the hardcoded values set at build time.  This makes it work like
the ds instance creation code.
Comment 4 Rich Megginson 2007-05-15 12:47:25 EDT
Created attachment 154751 [details]
cvs commit log

Fix Description: 1) viewlog had a couple of bugs.  I also added some tests for
viewlog
2) The start, stop, and restart scripts have been renamed
3) Move the cgid socket to /var/run/fedora-ds and rename to make it unique
4) Forgot the trailing slash on some of the paths in admserv.conf.  I also
needed to add the html directory, and fix the location match pattern matching
for the command and task urls
Comment 5 Rich Megginson 2007-05-15 19:00:34 EDT
Created attachment 154784 [details]
cvs commit log

Fix Description: 1) Change the pre configuration program to use the standard
adminutil pset and admldapInfo interfaces to get the default configuration
information.  No sense having code duplicated all over the place.
2) Change pre-config to allow passed in config, security, log, and pid
directories, or get from env. vars., as the post-config (update) program does.
3) Removed the Apache stuff.  This will be set during the build process.
Comment 6 Rich Megginson 2007-05-21 11:55:11 EDT
Created attachment 155102 [details]
cvs commit log

Fix Description: 1) Fixes for RHEL5 and Apache 2.2 - the existing code for
handling Apache 2.2 did not work, including cgisock code in httpd.conf
2) better support for mod_nss detection - look in several places for pcache and
module
3) admin server post install will mkdirs that it uses if they do not already
exist, and set permissions appropriately
4) use --variable=libdir with nss pkg-config to get the libdir - --libs-only-L
returns nothing if the library is already in the system libdir - we need the
actual libdir in every case because we have to use it in the ld_preload in the
startup script
Comment 7 Nathan Kinder 2007-12-14 18:19:42 EST
We have been building and running adminserver for some time using autotools and
FHS now.  Marking as VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.