Bug 239505 - Fatal error on installing kernel-xen
Summary: Fatal error on installing kernel-xen
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-xen   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Xen Maintainance List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-08 23:35 UTC by Kai Engert (:kaie) (inactive account)
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 23:56:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kai Engert (:kaie) (inactive account) 2007-05-08 23:35:14 UTC
Description of problem:
Up to date Rawhide i386 system.
Installing xen for the first time.
I used
  yum install kernel-xen xen virt-manager

The packages got installed, but the following error message was produced:
  Installing: kernel-xen                   ######################### [1/1]
FATAL: Could not open '/boot/System.map-2.6.20-2925.5.fc7xen': Permission denied
grubby fatal error: unable to find a suitable template

The files look ok:
[root@leise ~]# ls -l /boot/ |grep -i 2925
-rw-r--r-- 1 root root   67683 2007-03-22 19:04 config-2.6.20-2925.5.fc7xen
-rw------- 1 root root 2730974 2007-05-09 01:34 initrd-2.6.20-2925.5.fc7xen.img
-rw-r--r-- 1 root root  875161 2007-03-22 19:04 System.map-2.6.20-2925.5.fc7xen
-rw-r--r-- 1 root root 2191347 2007-03-22 19:04 vmlinuz-2.6.20-2925.5.fc7xen
-rw-r--r-- 1 root root  279722 2007-03-22 18:48 xen.gz-2.6.20-2925.5.fc7
-rwxr-xr-x 1 root root  711828 2007-03-22 19:05 xen-syms-2.6.20-2925.5.fc7

But file /etc/grub.conf did NOT get updated with the xen kernel.

I tried
  yum erase kernel-xen
  yum install kernel-xen

But I got the same error message again.


Version-Release number of selected component (if applicable):
xen-3.0.4-9.fc7
kernel-xen-2.6.20-2925.5.fc7

Comment 1 Kai Engert (:kaie) (inactive account) 2007-05-08 23:56:42 UTC
Maybe this bug should be set as invalid.

I have two hard disks, one SCSI, one IDE.

Both had partitions with / and /boot labels.

In the past I used explicit device names and everything was fine.

Recently, when ATA was introduced, all devices are now /dev/sdx, and worse,
different kernel versions produce different devide to /dev/sdx assignments. I
was forced to switch to labels, but forgot to check for duplicate labels.

So, at the time I ran into this failure, I had the wrong /boot partition
mounted. I didn't check what caused it, but fixed the labels.

I've now been able to install kernel-xen correctly.



Note You need to log in before you can comment on or make changes to this bug.