Bug 239522 - mkinitrd copies only 20 chars from root=
Summary: mkinitrd copies only 20 chars from root=
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-09 03:15 UTC by Doncho Gunchev
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-01 20:51:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Doncho Gunchev 2007-05-09 03:15:25 UTC
Description of problem:
After at some point the kernel stopped booting with root=LABEL=/ I switched to
/dev/VG12345/LVroot1 (I have FC6 too). When a new kernel was available and I
rebooted the new one loaded my FC6 (/dev/VG12345/LVroot).

Version-Release number of selected component (if applicable):
mkinitrd-6.0.9-1

How reproducible:
always, for the last 3 kernels I installed at least.

Steps to Reproduce:
1. install F7
2. edit grub.conf so root=/dev/VG12345/LVroot1 instead of root=LABEL=/
3. update the kernel rpm
4. look at grub.conf

Actual results:
the root device gets truncated to 19 characters.

Expected results:
Using device paths instead of labels should work, haven't tested with LABEL>19
characters.

Additional info:
mount shows me that I have /dev/mapper/VG12345-LVroot on / type ext3 (rw), but
that is not true. Maybe that's what confuses mkinitrd...

Comment 1 Doncho Gunchev 2007-05-14 00:37:12 UTC
My grub.conf starts with:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,1)
#          kernel /vmlinuz-version ro root=/dev/VG12345/LVroot1
#          initrd /initrd-version.img

and every time new kernel is installed I get:
        kernel /vmlinuz-version ro root=/dev/VG12345/LVroot
(no 1 at the end)
  The option root=LABEL=/ now works, didn't with one kernel, and I have to
modify this line every new kernel (even xen one) gets installed.

I'm changing even the comment to see what will happen next time...

PS: I have /dev/VG12345/LVroot and it is FC6, while /dev/VG12345/LVroot1 is F7.

Comment 2 Doncho Gunchev 2007-05-25 21:53:08 UTC
Ops. I searched in /etc and I think I found the problem. When one of the
development kernels did not boot I changed all LABEL=/ with /dev/VG (and typed
LVroot instead of LVroot1 for '/')... After that I have forgotten to revert
/etc/fstab, and that's from where new kernels have been getting their root=
option. My '/' entry in fstab was wrong (LVroot, not LVroot1), but that seems to
make no difference anywhere else ?!? Even mount shows LVroot, but the real
contents is from LVroot1 ?!? cat /proc/mounts is correct of course.

It is clear that the problem is not what I thought, but have no idea what to do
with this bug report now.

Comment 3 Doncho Gunchev 2007-06-01 20:51:54 UTC
In short, my fault - not a bug.


Note You need to log in before you can comment on or make changes to this bug.