Bug 239528 - yumdownloader do nothing when downloading SRPMS
Summary: yumdownloader do nothing when downloading SRPMS
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-09 06:56 UTC by Ken YANG
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-16 07:29:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ken YANG 2007-05-09 06:56:27 UTC
Description of problem:

yumdownloader do nothing when downloading SRPMS

Version-Release number of selected component (if applicable):

yum-utils-1.1.3-1.fc7  in fc7 rawhide

How reproducible:

yumdownloader --enablerepo development-source --source selinux-policy

  
Actual results:

Loading "installonlyn" plugin
Loading "skip-broken" plugin
development-source        100% |=========================|  951 B 00:00
primary.xml.gz            100% |=========================| 304 kB 00:03
developmen: ################################################## 1150/1150
Excluding Packages in global exclude list
Finished


Expected results:

down the SRPMS


Additional info:

there is nothing download, i also try:

yumdownloader --enablerepo development-source --source
selinux-policy-2.6.1-1.fc7.src.rpm

but obviously, the argument is wrong.

Comment 1 Tim Lauridsen 2007-05-09 10:06:35 UTC
I have fixed it in upstream CVS, it will be available in yum-utils-1.1.4.

I have also made it a little smarter so it auto enables the source repos for all
enabled repos (if it exists)

so this will work:
yumdownloader --source selinux-policy

Comment 2 Will Woods 2007-05-09 14:40:14 UTC
Does yum-utils-1.1.4 contain just bugfixes? Do you plan to have it available for
F7 final?

Comment 3 Tim Lauridsen 2007-05-10 08:28:20 UTC
The following changes will be available in yum-utils-1.1.4.
* Changes to make the '--source' with yumdownloader (This bugzilla report)
* Some patches to the security plugin (James Antill & Luke Macken)
  These patches depends on unreleased changes in yum.
  I think there will be a yum 3.2 release before F7 final, there include these
changes.

I think i will wait to after the F7 release and push it as an update. 

Comment 4 Ken YANG 2007-05-10 08:49:13 UTC
thanks for your work.

i can not wait the fc7 release, so i download directly from cvs :-)
it's just python script. 
i have used and work well

Comment 5 Rahul Sundaram 2007-05-15 00:39:22 UTC
Tim Laurisden,

Having this feature broken in Fedora 7 is going to affect a lot of users. This
is a feature mentioned rather prominently in the release notes amoung other
places. Please update yum-utils and fix this issue.



Comment 6 Tim Lauridsen 2007-05-15 07:53:43 UTC
Look like it to late to get it in Fedora 7.
https://www.redhat.com/archives/fedora-maintainers/2007-May/msg00351.html
But i will push it as soon as possible to get it into updates.


Comment 7 Rahul Sundaram 2007-05-15 17:48:55 UTC
It's not too late. Deep freeze is only on Thursday. You still have time and even
after thursday you can always ask rel eng. Please fix. 

Comment 8 Tim Lauridsen 2007-05-16 08:25:22 UTC
Ok, i have made a upstream yum-utils-1.1.4 release and build it in koji and
mailed the release team and ask them to include it in Fedora 7 Final.


Comment 9 Axel 2007-06-16 00:20:07 UTC
About the new syntax :
yumdownloader --source mail-notification
It works well, but when adding --enablerepo=fedora-source parameter, it does
nothing :

[root@localhost ~]# yumdownloader --source mail-notification
Loading "installonlyn" plugin
Enabling fedora-source repository
Enabling updates-source repository
mail-notification-4.0-2.f 100% |=========================| 940 kB    00:01     
[root@localhost ~]# yumdownloader --source --enablerepo=fedora-source
mail-notification
Loading "installonlyn" plugin
Enabling fedora-source repository
Enabling updates-source repository
[root@localhost ~]# 


Comment 10 Tim Lauridsen 2007-06-16 07:29:47 UTC
This is because the file is already downloaded, but is not telling you so. this
is fixed in upstream CVS, know it tell you that the file already is downloaded.


Note You need to log in before you can comment on or make changes to this bug.