Bug 23954 - Can't create database RH7 8.1.7. ORA-03114
Can't create database RH7 8.1.7. ORA-03114
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-13 11:57 EST by Carlos Villanueva
Modified: 2016-11-24 10:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 05:22:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Villanueva 2001-01-13 11:57:40 EST
Install Oracle database 8.1.7 release crash when try to create the
database, 
My system have RH7.0, kernel 2.4.0, glibc 2.2.12, what we can do for the
Oracle database work?
Comment 1 Carlos Villanueva 2001-01-13 12:33:15 EST
this are the errors
ORA-03113
end-of-file on communication channe

ORA-03114
not connect to oracle
Comment 2 Jakub Jelinek 2001-01-15 06:47:21 EST
Have you installed Oracle using procedure described in #18391, particularly
was it linked against compat-glibc?
Comment 3 Carlos Villanueva 2001-01-17 10:53:13 EST
jakup
I read about you in another bugs and you say the same to all.
I sorry to say it not work.
Comment 4 Need Real Name 2001-02-07 21:31:59 EST
I am following these bugs as well. The linking against glibc-compat works for the apps but is a totally bogus solution as far as i'm concerned.  Has 
anyone been able to isolate why the new glibc fails?  Is there a version that we can move to that does work? As i have stated in my other bugs i have 
updated it is crucial that RedHat 7.x work with Oracle.  You need the kernel 2.4.1 support of journaling filesystems, raid (working raid), and smp support 
to run any good database.  Redhat 6.2 just doesn't cut it.
Comment 5 Carlos Villanueva 2001-02-10 14:04:50 EST
this is a workaround to the technet oracle linux
I think this is clean and to very clear to follow is something like woraround of
jakub
I try it widt RH 7.0 glibc 2.2.12 and kernel 2.4.1
I use  compat-glibc-6.2-2.1.3.2.i386.rpm
------------------------------------------
Author 
                               Topic:   If you're having problems with Oracle
8.1.x on Linux, READ  THIS 
    John Smiley
    (smiley@lucent.com)
    unregistered 
                                  posted January 31, 2001 07:22 AM               

                               I have received so many emails lately that I
thought it would help to
                               re-post this under a different topic to make it
easier to find.

                               If you're having trouble with Oracle 8.1.x on any
version of Linux that
                               uses glibc version 2.2, try this and see if it
solves your problem:

                               The problem is that Oracle 8.1.x needs glibc
2.1.3. It will link without
                               error with glibc 2.2, but when you try to run
dbassist or create a
                               database from scratch, there are problems
(dbassist hangs, "End of file
                               on communication channel", etc.)

                               Here is a step-by-step process for getting Oracle
8.1.6 or 8.1.7 working
                               on systems with glibc 2.2 (don't bother with
8.1.5 if you can help it):

                               1. Install the compat-glibc RPM for 2.1.3.x

                               2. cd to the directory where compat-glibc
installed the files (for me it's
                               /usr/i386-glibc21-linux/lib).

                               3. Copy the following files to $ORACLE_HOME/lib:

                               libc-2.1.3.so
                               libpthread.so
                               libdl.so
                               ld-linux.so.2 

                               For me, several of these are symbolic links, so
you'll need to copy the
                               target of the symbolic link and rename it to the
link name when you copy
                               it to $ORACLE_HOME/lib.

                               For example, if ls -l shows:

                               ld-linux.so.2 -> ld-2.1.3.so
                               libc-2.1.3.so
                               libdl.so -> libdl.so.2
                               libpthread.so -> libpthread.so.0

                               Then you will:

                               cp ld-2.1.3.so $ORACLE_HOME/lib/ld-linux.so.2
                               cp libc-2.1.3.so $ORACLE_HOME/lib
                               cp libdl.so.2 $ORACLE_HOME/lib/libdl.so
                               cp libpthread.so.0 $ORACLE_HOME/lib/libpthread.so

                               4. Create a file in $ORACLE_HOME/lib called
libc.so with the following
                               contents (as a single line):

                               GROUP ( <OH>/lib/libc-2.1.3.so
<OH>/lib/ld-linux.so.2
                               <CL>/libc_nonshared.a )

                               Substitute the value of $ORACLE_HOME for <OH> and
the location of the
                               compat-glibc directory for <CL>. For example:

                               My $ORACLE_HOME is:
                               /u01/app/oracle/product/8.1.7

                               (Notice the use of the OFA standard? Do yourself
and others a favor -
                               follow the standard. If you don't know what OFA
is, please see the
                               Oracle Administrator's Guide for UNIX.)

                               and my compat-glibc directory is:

                               /usr/i386-glibc21-linux/lib

                               so the GROUP line looks like this for me:

                               GROUP
(/u01/app/oracle/product/8.1.7/lib/libc-2.1.3.so
                               /u01/app/oracle/product/8.1.7/lib/ld-linux.so.2
                               /usr/i386-glibc21-linux/lib/libc_nonshared.a)

                               This is all one line.

                               5. cd $ORACLE_HOME/bin

                               6. Run the following command from the UNIX
prompt:

                               relink all

                               All of the Oracle software, including the
assitants, will work fine now.

                               I have used this technique for RedHat 7.0 with
the 2.2.16 kernel, as well
                               as the 2.4.0 and 2.4.1-pre11 kernels.

                               Thanks to Richard Rankin for this simple and
reliable method (there are
                               others, but they are not as clean).

                               John Smiley
                               Sr. Oracle DBA
                               Lucent Technologies, Inc.

-----------------------------------------
saludos
Comment 6 Need Real Name 2002-01-17 04:27:14 EST
Eventhough, I did all the above, I am unable to relink oracle, it fails.
Any idea?
Comment 7 Ulrich Drepper 2003-10-03 05:22:58 EDT
Oracle relies on compatibility of object files with is *not* guaranteed.  So
they have some way to work around the problem.  These methods are all done by
Oracle, it's their problem, and as far as I know they document it.  Closing this
bug.

Note You need to log in before you can comment on or make changes to this bug.