Bug 239545 - Please update goffice to 0.4 branch
Please update goffice to 0.4 branch
Status: CLOSED DUPLICATE of bug 240689
Product: Fedora
Classification: Fedora
Component: goffice (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-09 07:08 EDT by Julian Sikorski
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-26 08:54:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2007-05-09 07:08:56 EDT
Would it be possible to update goffice to 0.4 branch? 0.4.0 was just released
and it is required for 0.8 branches of gnome-chemistry-utils and gchempaint
which will be released next week. I know we are at devel freeze right now, but
once it is over, would you mind updating rawhide and f7? Apart from gchemutils,
packages dependent on goffice are abiword and gnumeric. I don't know if they
will work with the new branch with just a rebuild, or will some additional work
be needed.

Regards,
Julian
Comment 1 Hans de Goede 2007-05-09 07:14:57 EDT
I'm the gnumeric maintainer myself, adding the abiword maintainer to the CC.
<uwog> can you see if abiword will work with the new goffice?

I'll take a look at this as time permits (rather busy atm), and try to update
somewhere early in the F8 cycle.
Comment 2 Julian Sikorski 2007-05-09 07:22:04 EDT
What I really would like to see is the update of f7 branch. Hopefully release
engineering would not have anything against that provided we sort it out among
ourselves.
Comment 3 Hans de Goede 2007-05-09 07:26:05 EDT
Maybe, first we need to get goffice (and libgda and libgnomedb, and gnumeric and
abiword and ...) all updated and tested in devel. Then we can ask rel-eng if
they are ok with pushing the whole set as "one" update to F7.
Comment 4 Julian Sikorski 2007-05-09 07:32:31 EDT
Sound reasonable. The thing is that new gchem* branch contains some nice
improvement, and waiting the whole release cycle for update seems like a bit of
a loss for the users. I'll do what I can to help with testing.
Comment 5 Marc Maurer 2007-05-09 10:17:15 EDT
Short answer: AbiWord 2.5 should work with goffice 0.4, but 2.4 will not.
Comment 6 Hans de Goede 2007-05-09 10:48:46 EDT
(In reply to comment #5)
> Short answer: AbiWord 2.5 should work with goffice 0.4, but 2.4 will not.

I see devel is currently on 2.4, do you plan / it is feasible to update F8 to
2.5 once the F8 cycle begin? Would it be a good idea to release this as an
update to F7 somewhat later then?
Comment 7 Julian Sikorski 2007-05-09 14:43:38 EDT
Hans: How about gnumeric? I have noticed that 1.7 is already out and some
goffice trunk reqs, so it looks like there are no major problems.
Marc: Do you know when 2.5 is planned to be released?
Comment 8 Hans de Goede 2007-05-09 14:48:02 EDT
The 1.7 branch is the unstable branch. i haven't looked yet if gnumeric-1.6.x
will work with goffice-0.8, and if not what patches are needed.
Comment 9 Julian Sikorski 2007-05-09 14:54:41 EDT
Ah, it is unstable, I missed that. Thx for info.
Comment 10 Julian Sikorski 2007-05-09 15:55:19 EDT
I read that goffice-0.2.x and 0.4.x can be installed in parallel, so I might
wrap up goffice04 package if no better solutions will be available.
Comment 11 Julian Sikorski 2007-05-09 15:59:10 EDT
Comment #7 errata: I mean 2.6, of course.
Comment 12 Marc Maurer 2007-05-10 10:18:50 EDT
Comment 6: For FC8 2.5 might be ready for inclusion, but we do not have a fixed
date for the final 2.6 yet. 

Also I see no reason why we couldn't issue an update for FC7 when 2.6 is out, as
we will be fully backwards compatible (except for some changed command line
options).
Comment 13 Bill Nottingham 2007-05-14 14:55:36 EDT
As the other goffice user, I should probably check gnucash. More later.
Comment 14 Hans de Goede 2007-05-26 08:54:08 EDT
This has been resolved by adding a seperate parallel installable goffice04
package for now (until all dependend packages can be built against 0.4)

Closing as a dup of the review of the goffice04 package

*** This bug has been marked as a duplicate of 240689 ***

Note You need to log in before you can comment on or make changes to this bug.