Bug 23955 - /sbin/hotplug kills ppp
/sbin/hotplug kills ppp
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-13 12:27 EST by Frank Sweetser
Modified: 2007-04-18 12:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-23 06:11:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Frank Sweetser 2001-01-13 12:27:43 EST
When bringing a ppp interface up, it seems that /sbin/hotplug kills pppd. 
Running from the debug window of rp3-config works fine, though. 
/var/log/messages bit  attached.
Comment 1 Frank Sweetser 2001-01-13 12:33:30 EST
Jan 13 11:21:10 localhost ifup-ppp: pppd started for ppp0 on /dev/ttyS1 at
115200
Jan 13 11:21:10 localhost kernel: PPP generic driver version 2.4.1
Jan 13 11:21:10 localhost pppd[1445]: pppd 2.4.0 started by root, uid 0
Jan 13 11:21:11 localhost WvDial: WvDial: Internet dialer version 1.41 
Jan 13 11:21:11 localhost WvDial: Initializing modem. 
Jan 13 11:21:11 localhost WvDial: Sending: ATZ 
Jan 13 11:21:11 localhost WvDial: ATZ 
Jan 13 11:21:12 localhost WvDial: OK 
Jan 13 11:21:12 localhost WvDial: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55
+FCLASS=0 
Jan 13 11:21:12 localhost WvDial: ATQ0 V1 E1 S0=0 &C1 &D2 S11=55 +FCLASS=0 
Jan 13 11:21:12 localhost WvDial: OK 
Jan 13 11:21:12 localhost WvDial: Modem initialized. 
Jan 13 11:21:12 localhost WvDial: Sending: ATDT 798-0166 
Jan 13 11:21:12 localhost WvDial: Waiting for carrier. 
Jan 13 11:21:12 localhost WvDial: ATDT 798-0166 
Jan 13 11:21:29 localhost WvDial: CONNECT 115200 
Jan 13 11:21:29 localhost WvDial: Carrier detected.  Waiting for prompt. 
Jan 13 11:21:31 localhost WvDial: Annex Command Line Interpreter   *   Copyright
(C) 1988, 1995 Xylogics, Inc. 
Jan 13 11:21:31 localhost WvDial: Checking authorization, Please wait... 
Jan 13 11:21:31 localhost WvDial: Use the upper case HELP keyword to get more
information about logging in; a 
Jan 13 11:21:31 localhost WvDial: username must be lower case. 
Jan 13 11:21:31 localhost WvDial: The current other keywords are ADMIT and
GUEST.  Use the HELP keyword for 
Jan 13 11:21:31 localhost WvDial: more information. 
Jan 13 11:21:31 localhost WvDial: CCC username:  
Jan 13 11:21:31 localhost WvDial: Looks like a login prompt. 
Jan 13 11:21:31 localhost WvDial: Sending: rasmusin 
Jan 13 11:21:31 localhost WvDial: rasmusin 
Jan 13 11:21:31 localhost WvDial: CCC password:  
Jan 13 11:21:31 localhost WvDial: Looks like a password prompt. 
Jan 13 11:21:31 localhost WvDial: Sending: (password) 
Jan 13 11:21:31 localhost WvDial: Permission granted 
Jan 13 11:21:31 localhost WvDial: Access to all WPI computer systems is
restricted to administratively authorized 
Jan 13 11:21:31 localhost WvDial: use only. 
Jan 13 11:21:32 localhost WvDial: port 2 ccc-modems:  
Jan 13 11:21:32 localhost WvDial: Hmm... a prompt.  Sending "ppp". 
Jan 13 11:21:33 localhost WvDial: ppp 
Jan 13 11:21:33 localhost WvDial: Switching to PPP. 
Jan 13 11:21:33 localhost WvDial: ~[7f]}#@!}!}!} }4}"}&} } } }
}%}&yxBd}'}"}(}".1~ 
Jan 13 11:21:33 localhost WvDial: PPP negotiation detected. 
Jan 13 11:21:33 localhost pppd[1445]: Serial connection established.
Jan 13 11:21:33 localhost pppd[1445]: Using interface ppp0
Jan 13 11:21:33 localhost pppd[1445]: Connect: ppp0 <--> /dev/ttyS1
Jan 13 11:21:33 localhost pppd[1445]: Terminating on signal 15.
Jan 13 11:21:33 localhost pppd[1445]: Connection terminated.
Jan 13 11:21:33 localhost /sbin/hotplug: /sbin/hotplug: event type 'net'
unsupported
Jan 13 11:21:33 localhost pppd[1445]: Hangup (SIGHUP)
Jan 13 11:21:33 localhost pppd[1445]: Exit.
Comment 2 Glen Foster 2001-01-15 16:51:15 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 3 rickf 2001-01-17 14:35:37 EST
in Beta 2 on my laptop system this is occurring even in the configuration
editor.  Definately a 
must fix.
Comment 4 Nalin Dahyabhai 2001-01-22 19:30:09 EST
The hotplug script isn't too bright.  It gets a 'interface ppp0 has been
created' notification from the kernel, so it runs "ifup ppp0", which kills pppd
and dials up.  Lather, rinse, repeat.

Than, would you verify that this fix (hotplug-S20001126a-0.3) doesn't break ISDN
and related things?
Comment 5 Ngo Than 2001-01-23 05:49:41 EST
i have checked it. It's ok with isdn and adsl.
Comment 6 Ngo Than 2001-01-23 06:11:12 EST
oh sorry, it will break ISDN too. I have a hotplug-S20001126a-0.4.src.rpm in my
home.
which does not ifup/ifdown isdn and ippp device. please rebuilt it.

Note You need to log in before you can comment on or make changes to this bug.