Bug 239556 - fedora-logos needs redhat-artwork
Summary: fedora-logos needs redhat-artwork
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-logos   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F8Target
TreeView+ depends on / blocked
 
Reported: 2007-05-09 13:47 UTC by Thomas Woerner
Modified: 2013-03-06 03:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-16 04:26:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Woerner 2007-05-09 13:47:29 UTC
Description of problem:
A minimal installation of F7/devel results in installed libX* packages
altogether with gtk2, because fedora-logos requires redhat-artwork.

Why is there a requirement for redhat-artwork and hicolor-icon-theme.
Why is fedora-logos providing some Bluecurve icons and icons for gnome at all?

Version-Release number of selected component (if applicable):
fedora-logos-6.0.98-3.fc7

How reproducible:
Everytime

Steps to Reproduce:
1. Install a minimal system (@core) only.
2.
3.
  
Actual results:
Installation of lots of not wanted packages.
Requirements: fedora-logos -> redhat-artwork -> gtk2-engines -> gtk2 -> libX11, ...

Expected results:
Minimal installation without gtk2, libX*, ..

Additional info:

Comment 1 Matthias Clasen 2007-05-09 17:05:24 UTC
thats what draconic directory ownership rules do to you...

Comment 2 Matthias Clasen 2007-05-09 17:06:19 UTC
there will be some changes in redhat-artwork packaging post-f7 that may improve
the situation...

Comment 3 Matthias Clasen 2007-06-16 04:26:22 UTC
* Fri Jun 15 2007 Adam Jackson <ajax@redhat.com> 6.0.98-4
- Remove the Requires on redhat-artwork and fedora-icon-theme, and just
  multi-own the directories.  Fixes some hilarious dependency chains.




Note You need to log in before you can comment on or make changes to this bug.