Bug 239570 - consolehelper problem on X forwarded Python programs
consolehelper problem on X forwarded Python programs
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: usermode (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-09 11:32 EDT by W.C. Epperson
Modified: 2008-04-04 09:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 09:41:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W.C. Epperson 2007-05-09 11:32:59 EDT
Description of problem:

consolehelper appears to be hosing up MIT-MAGIC-COOKIE-1 authentication on ssh
-X connected session, preventing normal remote use of system-config-users and
similar programs.

This is essentially similar to Fedora bug #239395, except that I have a system
with the environment described there and cannot reproduce the problem there.

Version-Release number of selected component (if applicable):

Component is /usr/bin/consolehelper in at least the following package/release
environments:
usermode-1.74-1 on Red Hat Enterprise Linux ES release 4 (Nahant Update 4)
usermode-1.68-5 on Red Hat Enterprise Linux ES release 3 (Taroon Update 3)
usermode-1.63-1 Red Hat Linux release 8.0 (Psyche)

Various Dell Poweredge servers and Optiplex desktops.
The RHEL4 system is fully updated with up2date, including kernel packages.
The problem does not occur in usermode-1.87-3 under Fedora Core release 6 (Zod)
on a Dell Precision 530, also fully updated with yum.

How reproducible:

The problem appears to occur with any X-forwarding ssh program, including PuTTY
under Windows.  It appears to be limited to Python-based programs run via
consolehelper, e.g. system-config-users exhibits the problem,
system-config-printer does not.  Running the wrapper script directly from the
command line (/usr/share/system-config-users/system-config-users) does not
exhibit the problem.

Steps to Reproduce:
1. ssh -X <host> (or PuTTY with X11 Forwarding enabled)
2. Run system-config-users (or redhat-config-users on RH8, RHEL3) or any
Python-based consolehelper-assisted program.
  
Actual results:
# system-config-users
Xlib: connection to "localhost:10.0" refused by server
Xlib: PuTTY X11 proxy: wrong authentication protocol attempted
system-config-users requires a currently running X server.

Expected results:

system-config-users gui session on X-server.

Additional info:

The error messages delivered by ssh and PuTTY, the stderr of ssh -X -vvv, and
reading of the ssh and PuTTY source code suggest that consolehelper is somehow
munging up the MIT-MAGIC-COOKIE-1 authentication.
Comment 1 W.C. Epperson 2007-05-10 10:44:33 EDT
Errata:
"Running the wrapper script directly from the
command line (/usr/share/system-config-users/system-config-users) does not
exhibit the problem."

should be

"Running the Python script directly from the
command line (/usr/share/system-config-users/system-config-users.py) does not
exhibit the problem."
Comment 2 Tomas Mraz 2008-04-04 09:41:09 EDT
Deferred to later Red Hat Linux Enterprise releases.

Note You need to log in before you can comment on or make changes to this bug.