Bug 239607 - List Filter Usability Issues with Unsuccessful Filter Terms
List Filter Usability Issues with Unsuccessful Filter Terms
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Usability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
:
Depends On:
Blocks: 248643 317791
  Show dependency treegraph
 
Reported: 2007-05-09 16:46 EDT by Máirín Duffy
Modified: 2008-04-02 22:11 EDT (History)
0 users

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 17:08:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of suggested improvements (37.73 KB, image/png)
2007-05-10 12:19 EDT, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2007-05-09 16:46:37 EDT
(1) When you filter a list on either a java or a perl page for a term that does
not exist in the set (try filtering for the term 'aslkjglaskfj'), the filter
controls disappear.

(2) Because the filter controls disappear, there is no way to clear filters for
terms that don't exist in the list.

PROPOSED USE CASE to fix this
=============================

SCENARIO: I don't have any rlx systems registered to my satellite. I don't know
this, and I want to know if I do have rlx systems. So...

(1) I search for 'rlx' in my system list filter box. 

(2) The list is returned to me, with the columns visible but no data rows.
Instead, the inside of the list is empty and has a message: "No systems found
containing 'rlx.' _Clear this filter and view all systems_" If I click on this
link, the filter will be cleared and I will be able to view all the systems in
that particular list again.

(3) Additionally, the filter box controls still appear at the top of the list,
with the string 'rlx' in the text input box. If I deleted the text in the text
input box, and clicked the 'go' submit button, I will be able to view all the
systems in that particular list again.

p.s. use case above should be used as a test plan later on.
Comment 1 Máirín Duffy 2007-05-10 12:19:51 EDT
Created attachment 154483 [details]
example of suggested improvements
Comment 2 wes hayutin 2007-05-11 10:00:18 EDT
nice change! 
Comment 4 Justin Sherrill 2007-10-03 15:27:52 EDT
fixed in new list tag in rev 132463
Comment 5 Justin Sherrill 2007-10-03 17:04:48 EDT
For now i'm just going to fix this in the new list tag which includes some of
the more popular pages (System list, System Group list, user list, etc..).  

If we want to fix this in any of the old list tag pages, it might be easier just
to port that page to the new list tag.

For testing, I'd just test:
/rhn/systems/SystemList.do
/rhn/systems/SystemGroupList.do
/rhn/users/ActiveList.do
Comment 6 Justin Sherrill 2007-10-05 16:24:11 EDT
moved on qa
Comment 7 wes hayutin 2007-10-10 15:43:09 EDT
verified in build 14..
systems and users
Comment 9 John Ha 2007-12-12 21:39:49 EST
Here is a release note for this issue as suggested by Mairin:

 Users, Systems, and System Group filter strings can now be
 cleared to display the complete list.
Comment 10 Preethi Thomas 2008-03-25 08:31:43 EDT
rlease pending
Comment 11 Brandon Perkins 2008-04-02 17:08:04 EDT
UI Enhancements for 5.1 Sat GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.