Bug 239666 - very high scheduling latency when restart X
Summary: very high scheduling latency when restart X
Status: CLOSED DUPLICATE of bug 239665
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.4
Hardware: All Linux
medium
high
Target Milestone: ---
: ---
Assignee: Kernel Maintainer List
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-10 13:02 UTC by Eddy Zhao
Modified: 2007-11-17 01:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-27 18:09:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eddy Zhao 2007-05-10 13:02:49 UTC
Our realtime app is troubled by a realtime problem related to X on RHEL4U4, you 
can reproduce the problem like below
 
 * run RHEL4U4
 * boot into runlevel 5
 * killall -9 X
 * system scheduling latency (+ interrupt latency) jumps to 6382ms!! 

I'm using realfeel to measure scheduling latency, you can find the tool below
(PS. before compiling the tool, you should change SAMPLES to larger value, eg. 
10000000)
 
  http://www.captain.at/howto-captest.tar.gz
  http://www.captain.at/howto-linux-real-time-patch.php

The problem was reproduced on 3 test machines, all have configuration below
 
 * /etc/redhat-release
     Red Hat Enterprise Linux AS release 4 (Nahant Update 4)
 * uname -a
     Linux localhost.localdomain 2.6.9-42.EL #1 Wed Jul 12 23:16:43 EDT 2006 
i686 i686 i386 GNU/Linux
 * lspci | grep VGA
     00:02.0 VGA compatible controller: Intel Corporation 945G/GZ Express 
Integrated Graphics Controller (rev 02)

Test result is below

  0.0 15214
  0.1 3
  0.2 373
  0.3 3
  0.4 91
  0.6 1
  3.1 1
  4.1 1
  6382.4 1
 
If using smp kernel, scheduling latency jumps to 100ms

Comment 1 Jay Fenlason 2007-09-27 18:09:27 UTC

*** This bug has been marked as a duplicate of 239665 ***


Note You need to log in before you can comment on or make changes to this bug.