Bug 239673 - RHEL 5: stalled installation over HP Compaq 7700
RHEL 5: stalled installation over HP Compaq 7700
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tony Camuso
Martin Jenner
: OtherQA, Reopened
Depends On: 219389
Blocks: 246139 296411 372911 420521 422431 422441
  Show dependency treegraph
 
Reported: 2007-05-10 10:25 EDT by Prarit Bhargava
Modified: 2010-10-22 10:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:42:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Prarit Bhargava 2007-05-10 10:26:43 EDT
I do not have one of these in Westford.  I have provided Florian instructions on
downloading and installing a test kernel for his 7700.

P.
Comment 3 RHEL Product and Program Management 2007-05-10 12:04:36 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Prarit Bhargava 2007-07-26 10:47:38 EDT
Re-assigning this to tcamuso.

P.
Comment 11 Tony Camuso 2007-11-08 08:33:21 EST
ACK
Comment 14 Tony Camuso 2007-12-11 06:39:00 EST
Prarit, 

I think this might be related to the mmconf problem. The dc5700 is blacklisted
in RHEL5, but the dc7700 is not. 

I'm not sure the dc7700 use the same chipset as the dc5700, but it's very likely
to use it or one of the variants I've included in the device blacklist in the
patch. 

Can I forward a patch or a patched kernel to Florian to try?

Do you know if RHEL4 works on the dc7700? I don't see it blacklisted in RHEL4.
Comment 15 Prarit Bhargava 2007-12-11 06:56:27 EST
Hey Tony, this never got blacklisted because we (Westford) don't have a 7700 to
test with.  

The failure, however, is *exactly* the same.

P.
Comment 16 Prarit Bhargava 2007-12-11 06:57:43 EST
Oh -- I should also add that "pci=nommconf" fixed the boot problem on Florian's
7700 in Europe.

Bottom line -- the code never went in....

P.
Comment 17 Tony Camuso 2007-12-11 07:51:53 EST
Thanks, Prarit.

Now I'm more certain that the mmconf patch will fix the 7700. 
Comment 19 Tony Camuso 2007-12-18 21:13:31 EST
Upstream patch of the kernel will not be using the blacklist, and the existing
blacklist does not include dc7700. 

The workaround for dc7700 remains pci=nommconf in the boot command. 
Comment 20 Tony Camuso 2008-01-11 17:13:28 EST
I will be submitting a patch upstream that will fix the dc7700 and dc5700 problem. 

Here is a description of the problem. 

Bus sizing code writes 0xffffffff to the BARs to determine how
much space they require. The 82Q963/Q965 graphics controller
in the dc5700 wants to map 256MB, so the most significant bit
of the BAR at offset 0x18 is set to decode MMIO addresses with
the MSB set.

The BAR is a 64-bit BAR, and the upper 32-bits are probably 0,
so once we write the BAR with 0xffffffff, the device claims all
addresses in the range 0x00000000.f0000000 to 0x00000001.00000000
which happens to include the MMCONFIG range set up by the BIOS
for the dc5700.

At this point no more forward progress can be made, since all
MMCONFIG references are being claimed and swallowed by the
graphics chip.

There are several ways to address this.

1. A BIOS fix that places the MMCONFIG region in 64-bit space
   safely above 00000001.00000000 and out of reach of the
   graphics chip.

2. A change to the linux bus sizing algorithm to write
   0xffffffff to the upper dword of the 64-bit register
   before sizing the lower dword.

3. A change to the linux pci config access routines so that
   all references below offset 0x40 in pci config space are
   made with legacy pci config.

Most of the participants on the lkml, including me, believe that
option 3 is the best one, because it guarantees that BARs will
always be configured using legacy pci config access.

However, Graphics chips are very likely to claim ever larger
pieces of memory space, so it is still possible for the problem
to occur if sizing code places the base address of the graphics
device's 256MB address range within reach of the MMCONFIG area
mapped by the BIOS.

In the long run, the safest bet is for BIOS to map the MMCONFIG region into
memory space that is unlikely to be mapped by bus-sizing code. 

The patch I am going to submit was suggested by Ivan Shakaysky on the LKML. The
patch will use legacy PCI config access for the first 64 bytes of offset in PCI
config space. This means that the BARs will always be programmed by legacy PCI
config and temporarily mapping them into MMCONFIG space while conducting
bus-sizing will not hang the system. 

Comment 21 Don Zickus 2008-01-22 13:49:16 EST
in 2.6.18-72.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 23 John Poelstra 2008-03-20 23:59:57 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot1--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 24 John Poelstra 2008-04-02 17:40:33 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot3--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 25 John Poelstra 2008-04-09 18:46:12 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot4--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 26 John Poelstra 2008-04-23 13:41:40 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot6--available now on partners.redhat.com.  

We are nearing GA for 5.2 so please test and confirm that your issue is fixed ASAP.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 27 John Poelstra 2008-05-01 12:51:25 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot7--available now on partners.redhat.com.  

We are nearing GA for 5.2--this is the last opportunity to test and confirm that
your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 29 errata-xmlrpc 2008-05-21 10:42:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.