Bug 23970 - ext3 0.0.5e appears to attempt to modify filesystem even when mounted read-only
ext3 0.0.5e appears to attempt to modify filesystem even when mounted read-only
Status: CLOSED CURRENTRELEASE
Product: Red Hat High Availability Server
Classification: Retired
Component: ext3 (Show other bugs)
beta
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Wil Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-13 19:47 EST by Jay Weber
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 17:15:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2001-01-13 19:47:12 EST
Using LVM snapshot integration with ext3 I've noted that even if my ext3
filesystem which was
snapshotted was in a clean state at snapshot time (no needs_recovery flag
set) when that filesystem is mounted read-only (via mounting the LVM
snapshot) it appears to still try to modify the filesystem during the mount
procedure as I get back some "Bad lvm_map in ll_rw_blk" messages from LVM.

In all, I gather nothing is truely changed, but it does generate some
debugging noise from the kernel/LVM.  Looking at the code it looks like
this could be related to an iput() of the journal or such possibly, as the
code shows that the journal is the first thing addressed and has many
checks regarding it.
Comment 1 Red Hat Bugzilla 2001-05-07 16:51:27 EDT
Is this still an open problem?
Comment 2 Red Hat Bugzilla 2001-05-07 17:15:22 EDT
The current release works without the mentioned problem.  I'm using 0.0.6b now. 
I'm closing the bug.

Note You need to log in before you can comment on or make changes to this bug.