Bug 239706 - doesn't build on ppc64
Summary: doesn't build on ppc64
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hdf   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-10 17:12 UTC by Bill Nottingham
Modified: 2014-03-17 03:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-11 15:40:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
powerpc64 support (67.69 KB, patch)
2007-05-11 04:38 UTC, Balint Cristian
no flags Details | Diff

Description Bill Nottingham 2007-05-10 17:12:21 UTC
Build log at http://people.redhat.com/notting/hdf.log

Comment 1 Orion Poplawski 2007-05-10 17:38:34 UTC
Looks like we need to update hdf-4.2r1-ppc.patch to add support for ppc64.  Can
someone take a look at that patch and hdf/src/hdfi.h and see what would make
sense for ppc64? 

Comment 2 Balint Cristian 2007-05-10 17:46:09 UTC
I've try.
Give me couple of hours.

Comment 3 Balint Cristian 2007-05-11 04:36:32 UTC
Ughh..

Fixed couple of things, but netcdf tests still not pass.
I attach the patch, maybe you will look into too.

/me wonder how debian *just* build this for ppc64 without tests .....


Comment 4 Balint Cristian 2007-05-11 04:38:55 UTC
Created attachment 154516 [details]
powerpc64 support

Preliminary powerpc64 support, however netcdf stuff need more fixing.

Comment 5 Balint Cristian 2007-05-11 09:01:53 UTC
Yup !
http://koji.fedoraproject.org/koji/taskinfo?taskID=6319
builded fine.

grab from here:
SRPMS: http://openrisc.rdsor.ro/hdf-4.2r1-13.fc7.src.rpm

BTW,

1) keep in mind i disable one of subtest to pass over buggy netcdf tester 
routine ...

2) i would love to fix this since hdf render my ogdi,gdal,grass,mapserver 
unbuildable for fedora ppc64, and those will be excluded from release, so
if can please rebuild hdf.



Comment 6 Balint Cristian 2007-05-11 09:03:26 UTC
PS:

all other test should now be fined, there was tons of failures before, i fix 
all tham except netcdf ... (i wonder netcdf why was imported in hdf)


Comment 7 Orion Poplawski 2007-05-11 15:40:41 UTC
Thanks!  Checked in and built as hdf-4.2r1-14.fc7.


Note You need to log in before you can comment on or make changes to this bug.