Bug 23971 - up2date -u gives nonsensical RPM error about dependencies
Summary: up2date -u gives nonsensical RPM error about dependencies
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-14 02:18 UTC by Havoc Pennington
Modified: 2015-01-07 23:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-06 05:29:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:048 normal SHIPPED_LIVE New Update Agent with many fixes and enhanced functionality available 2001-04-12 04:00:00 UTC

Description Havoc Pennington 2001-01-14 02:18:38 UTC
6.2 system just upgraded to 7.0. Was using latest up2date bugfix errata on
6.2, just installed latest up2date errata for 7.0. up2date -u complains
that ['libk5crypto.so.3'] depends on libk5crypto.so.3, which makes no sense
to me, especially since that file exists on my system.

[root@rdu25-4-135 pkgs]# up2date -u

Retrieving list of all available packages...

Removing installed packages from list of updates...
100.0%
Removing packages marked to skip from list...
100.0%
Getting headers for available packages...
100.0%
Removing packages with files marked to skip from list...
100.0%
Testing package set / solving RPM inter-dependencies...
There was a fatal RPM error.  The message was:
Could not solve dependency libk5crypto.so.3, depended on by
['libk5crypto.so.3']
[root@rdu25-4-135 pkgs]# rpm -qi up2date
Name        : up2date                      Relocations: (not relocateable)
Version     : 2.1.7                             Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Thu 21 Dec 2000
03:57:47 PM EST
Install date: Sat 13 Jan 2001 07:18:49 PM EST      Build Host:
porky.devel.redhat.com
Group       : System Environment/Base       Source RPM: up2date-2.1.7-1.src.rpm
Size        : 228596                           License: GPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Automatically update RPMs for a Red Hat Linux Systemrequires
Description :
The Red Hat Update Agent automatically queries the Red Hat Network
servers and figures out what packages need to be updated on your box.
[root@rdu25-4-135 pkgs]# ls /usr/kerberos/lib/libk5crypto.so.3
/usr/kerberos/lib/libk5crypto.so.3

Comment 1 Cristian Gafton 2001-02-20 01:35:23 UTC
Assigned QA to jturner

Comment 2 Preston Brown 2001-03-06 05:28:58 UTC
dependency problem reporting is much improved in our next version, due out soon.

Comment 3 Preston Brown 2001-04-12 20:59:12 UTC
addressed in errata due out today.


Note You need to log in before you can comment on or make changes to this bug.