Bug 239724 - "powernow-k8: Processor cpuid 70ff1 not supported" on Athlon64 3800+ AM2 which supports Cool'n'Quiet
Summary: "powernow-k8: Processor cpuid 70ff1 not supported" on Athlon64 3800+ AM2 whic...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-10 19:31 UTC by Tomasz Ostrowski
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-15 19:05:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 8423 None None None Never

Description Tomasz Ostrowski 2007-05-10 19:31:12 UTC
Description of problem:
Powernow-k8 driver does not load - it shows a message
    powernow-k8: Processor cpuid 70ff1 not supported
on my new AMD Athlon64 3800+ on AM2 connector (Family: 15 Model: 15 Stepping:
1), which does support Cool'n'Quiet. Because of this I cannot use cpufreq in my
system.

Version-Release number of selected component (if applicable):
kernel-2.6.20-1.3104.fc7.i686

How reproducible:
Always

Steps to Reproduce:
1. Boot a Fedora 7test4 Life CD on affected system
2. Watch kernel messaged

Actual results:
powernow-k8: Processor cpuid 70ff1 not supported
powernow-k8 driver not loaded and cpuspeed not working

Expected results:
powernow-k8 driver loaded and working cpuspeed

Additional info:
Additional info and proposed (trivial) patch is on Linux Kernel Bugzilla:
http://bugzilla.kernel.org/show_bug.cgi?id=8423

Comment 1 Dave Jones 2007-05-15 19:05:47 UTC
fixed in cvs, will be in next build.



Note You need to log in before you can comment on or make changes to this bug.