This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 239727 - LVM2 mirror support in anaconda (configuration and root volume)
LVM2 mirror support in anaconda (configuration and root volume)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Joel Andres Granados
: FutureFeature
Depends On: 200294
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2007-05-10 16:03 EDT by Jun'ichi NOMURA
Modified: 2014-06-23 08:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-13 16:58:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pykickstart pathc to add mirroring options ot the lvm stuff. (2.61 KB, patch)
2007-08-27 14:34 EDT, Joel Andres Granados
no flags Details | Diff
Anaconda part of the patch. (13.03 KB, patch)
2007-08-27 14:37 EDT, Joel Andres Granados
no flags Details | Diff
updates image I used for my tests against f8t1 (1.00 MB, application/octet-stream)
2007-08-27 14:38 EDT, Joel Andres Granados
no flags Details
more logical kickstart option. (2.66 KB, text/x-patch)
2007-08-28 03:56 EDT, Joel Andres Granados
no flags Details
Fixed a bug that the initial patch had :) (13.04 KB, patch)
2007-08-28 03:58 EDT, Joel Andres Granados
no flags Details | Diff
Adding a LogVolData class for the new options. (4.70 KB, patch)
2007-08-31 09:32 EDT, Joel Andres Granados
no flags Details | Diff
Same functionality, different way of coding (13.01 KB, patch)
2007-08-31 09:37 EDT, Joel Andres Granados
no flags Details | Diff

  None (edit)
Description Jun'ichi NOMURA 2007-05-10 16:03:46 EDT
+++ This bug was initially created as a clone of Bug #200294 +++

Description of problem:
  Anaconda to enable LVM2 mirror configuration

Additional info:
  As of FC5, only linear mapped LV can be configurable in anaconda.
  Other mappings, especially mirror, needs to be configured.

-- Additional comment from clumens@redhat.com on 2007-05-02 11:47 EST --
I don't see how we could possibly add support for this, as it's going to be a
fairly major change with high risk of introducing new bugs.  It's also going to
involve a lot of UI and translation changes which we try to avoid for update
releases.  The correct way to do this is to get it on a bug list for F8 where we
can develop and test it, and then work it into the next major release of RHEL.

-- Additional comment from pm-rhel@redhat.com on 2007-05-02 12:01 EST --
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 1 Red Hat Bugzilla 2007-06-11 23:52:32 EDT
requested by Jams Antill
Comment 2 Joel Andres Granados 2007-08-27 14:34:51 EDT
Created attachment 174121 [details]
pykickstart pathc to add mirroring options ot the lvm stuff.
Comment 3 Joel Andres Granados 2007-08-27 14:37:03 EDT
Created attachment 174161 [details]
Anaconda part of the patch.
Comment 4 Joel Andres Granados 2007-08-27 14:38:47 EDT
Created attachment 174181 [details]
updates image I used for my tests against f8t1
Comment 5 Joel Andres Granados 2007-08-27 14:47:11 EDT
I only changed the kickstart part of the installation to activate mirroring. 
This I hope will serve as a test case for future changes in the gui and text
installs.  comments are *greatly* appreciated.
Comment 6 Joel Andres Granados 2007-08-28 03:56:21 EDT
Created attachment 175081 [details]
more logical kickstart option.
Comment 7 Joel Andres Granados 2007-08-28 03:58:51 EDT
Created attachment 175101 [details]
Fixed a bug that the initial patch had :)
Comment 8 Joel Andres Granados 2007-08-28 04:05:00 EDT
The updates image will be at http://jgranado.fedorapeople.org/updates.img
Comment 9 Joel Andres Granados 2007-08-31 09:32:50 EDT
Created attachment 183321 [details]
Adding a LogVolData class for the new options.
Comment 10 Joel Andres Granados 2007-08-31 09:37:42 EDT
Created attachment 183341 [details]
Same functionality, different way of coding

I changed some things in the code to reflect a discussion in the anaconda devel
list
https://www.redhat.com/archives/anaconda-devel-list/2007-August/msg00071.html  


In summary I created new classes and methods to implement the mirroring stuff
(as discussed in anaconda-devel).  the updates.img that I used will be
http://jgranado.fedorapeople.org/updates.img.

This patch does not Obsolete my previous patch to anaconda.  Its just a
different way of doing stuff:)
Comment 11 Joel Andres Granados 2009-04-21 05:13:54 EDT
With the storage rewrite going strong all these patches no longer apply.  This issue should be addressed for releases after f11.
Comment 12 Jeff Layton 2009-07-29 13:57:25 EDT
So is there an actual plan to make this happen in >= f12?

Given that bug 512594 was closed WONTFIX, is there actual interest in making this work?

This would be a good thing to have in place since it looks like barrier support is being fixed in LVM upstream.
Comment 13 Joel Andres Granados 2009-07-30 04:15:13 EDT
Its too late for f12, and there has not been a great effort to get this in.  Patches accepted :)

Note You need to log in before you can comment on or make changes to this bug.