Bug 239764 - bitwise matching plugin
bitwise matching plugin
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Database - Indexes/Searches (Show other bugs)
1.1.0beta
All Linux
medium Severity medium
: ---
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
:
Depends On:
Blocks: FDS1.1.0
  Show dependency treegraph
 
Reported: 2007-05-11 02:26 EDT by Andrew Bartlett
Modified: 2015-12-07 11:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:47:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to implement bitwise operations (8.50 KB, patch)
2007-05-11 02:26 EDT, Andrew Bartlett
no flags Details | Diff
cvs commit log (2.02 KB, text/plain)
2007-05-16 15:48 EDT, Rich Megginson
no flags Details

  None (edit)
Description Andrew Bartlett 2007-05-11 02:26:44 EDT
Description of problem:
Samba requires backend LDAP servers to support bitwise operations


Version-Release number of selected component (if applicable):
1.1 CVS

How reproducible:
Every time


Steps to Reproduce:
1. Search with filters like
(|(|(&(!(groupType:1.2.840.113556.1.4.803:=1))(groupType:1.2
.840.113556.1.4.803:=2147483648)(groupType:1.2.840.113556.1.4.804:=10))(samAccountType=805306368))(samAccountType=805306369))

2. 
3.
  
Actual results:
No match on the extended matching rule

Expected results:
Valid matches

Additional info:

This patch works for Samba's tests, but hasn't been more broadly or specifically
tested
Comment 1 Andrew Bartlett 2007-05-11 02:26:44 EDT
Created attachment 154518 [details]
Patch to implement bitwise operations
Comment 2 Noriko Hosoi 2007-05-11 12:38:45 EDT
Your implementation looks good. 
Comment 3 Rich Megginson 2007-05-16 15:48:24 EDT
Created attachment 154865 [details]
cvs commit log

I added an --enable-bitwise option to configure (on by default - use
--disable-bitwise to disable it).  I also added the plugin entry to the
configuration during new instance creation.
Comment 4 Andrew Bartlett 2007-07-24 21:22:27 EDT
Samba4 uses this nicely, what do we need to wait for to close this bug as fixed?
Comment 5 Rich Megginson 2007-07-25 10:42:39 EDT
(In reply to comment #4)
> Samba4 uses this nicely, what do we need to wait for to close this bug as fixed?

It takes a QA person to move this to the CLOSED/RESOLVED state.  All us poor
developers can do is to move it to the MODIFIED state, which means some lucky QA
person has the task of verifying this.

Unfortunately, we have no QA directly assigned to Fedora DS.

So, for all intents and purposes, we can treat this bug as resolved since
bitwise is included in Fedora DS and works for its intended purpose.
Comment 7 Chandrasekar Kannan 2009-06-22 19:44:06 EDT
(In reply to comment #0)
> Additional info:
> 
> This patch works for Samba's tests, but hasn't been more broadly or specifically
> tested  

Andrew - can you share or provide some information about where to find/view these samba tests ..
Comment 8 Andrew Bartlett 2010-03-12 04:49:28 EST
Endi,

I take it that now Fedora DS now works as a Samba backend that this is all done?

Certainly, the LDAP tests I'm describing are now part of the standard testsuite, and that is run against Fedord DS (389).
Comment 9 Endi Sukma Dewata 2010-03-12 12:25:17 EST
Hi Andrew,

We have a machine called buildsamba02 in the Samba build farm that is configured to run with DS backend. These are the test results:

http://build.samba.org/?function=View+Build;host=buildsamba02;tree=samba_4_0_test;compiler=gcc

As of today there are still about ~80 failures. Do you know which test cases involve bitwise operations?
Comment 11 Rich Megginson 2011-06-16 10:08:42 EDT
This is covered by the filter/bitw_filter.sh test.
Comment 12 Amita Sharma 2011-06-17 01:58:18 EDT
filter run Tests  PASS       : 100% (257/257)

Marking VERIFIED sanity.

Note You need to log in before you can comment on or make changes to this bug.