Bug 239772 - fence / libnss
Summary: fence / libnss
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: fence   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Chris Feist
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 241701
TreeView+ depends on / blocked
 
Reported: 2007-05-11 08:52 UTC by Christophe GUILLOUX
Modified: 2009-04-16 20:03 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0375
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-29 21:35:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unbreak dependencies (1.05 KB, patch)
2007-05-14 15:03 UTC, Lon Hohberger
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0375 normal SHIPPED_LIVE fence bug fix update 2007-12-06 22:03:12 UTC

Description Christophe GUILLOUX 2007-05-11 08:52:17 UTC
Description of problem:

depencies problem

Version-Release number of selected component (if applicable):

Unresolvable chain of dependencies:
fence  1.32.45-1                         requires libnss3.so
fence  1.32.45-1                         requires libnss3.so(NSS_3.2)
fence  1.32.45-1                         requires libnss3.so(NSS_3.4)

How reproducible:
With the last update of fence.

Actual results:

With the last update of fence, these is a new file required : libnss3.so
This file is in the package mozilla-nss-1.7.13-1.4.1.i386 but this is not
provide by the fence package.

Expected results:

1st problem : 
I don't think that an update should add a new depency. mozilla-nss is not a
important package so he is not installed on our server. It's a bad idee to
propose this new depency.
2nd problem : if libnss is really necessary then "fence" should ask "mozilla-nss"


I have set this ticket to "urgent" because it blocks important package update.

Comment 1 Nate Golnik 2007-05-12 02:09:50 UTC
Install seamonkey-nss for a work around.... like that's real obvious

Comment 2 Jay Turner 2007-05-14 14:54:25 UTC
The addition of the libnss3.so requirement was in order to facilitate xen
support and the ability to perform fencing on xen guests.  As was pointed out in
comment 1, seamonkey-nss will indeed satisfy the dependency.

Comment 3 Lon Hohberger 2007-05-14 15:03:01 UTC
Created attachment 154655 [details]
Unbreak dependencies

Fence.spec patch to require seamonkey-nss (the buildrequires already has
seamonkey-nss-devel)

Comment 4 Chris Feist 2007-05-18 17:29:54 UTC
Devel Ack & Requesting 4.6

Comment 10 Red Hat Bugzilla 2007-05-29 21:35:05 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0375.html



Note You need to log in before you can comment on or make changes to this bug.