Bug 239778 - Unable to display appropriate mode on T60 (1400x1050)
Unable to display appropriate mode on T60 (1400x1050)
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-i810 (Show other bugs)
5.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-11 06:19 EDT by Werner Gold
Modified: 2012-04-17 16:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 16:03:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
comparison of reported modes (915resolution and xorg) (11.04 KB, application/vnd.oasis.opendocument.spreadsheet)
2007-05-22 11:09 EDT, Werner Gold
no flags Details

  None (edit)
Description Werner Gold 2007-05-11 06:19:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.8) Gecko/20061108 Fedora/1.5.0.8-1.fc5 Firefox/1.5.0.8

Description of problem:
The i810 is obviously limited to the modes in the VGA BIOS. Unfortunately the resolution of the T60 display (1400x1050) is not in the list taken from the (additionally installed - not part of RHEL5) 915resolution (0.5.3)
Setting it with 915resolution to:
Mode 66 : 1400x1050, 8 bits/pixel
Mode 67 : 1400x1050, 16 bits/pixel
Mode 68 : 1400x1050, 24 bits/pixel
does not work.
From xorg.conf:
Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                #Virtual   1400 1050
                Modes "1600x1200" "1400x1050" "1280x1024" "1024x768"
                Depth     24
        EndSubSection
EndSection

From /var/log/Xorg.0.log:
(II) I810(0): Monitor0: Using hsync range of 60.00-66.32 kHz
(II) I810(0): Monitor0: Using vrefresh value of 60.00 Hz
(II) I810(0): Not using mode "1600x1200" (no mode of this name)
(II) I810(0): Not using mode "1400x1050" (no mode of this name)
(II) I810(0): Not using mode "1024x768" (no mode of this name)
(II) I810(0): Increasing the scanline pitch to allow tiling mode (1280 -> 2048).
(--) I810(0): Virtual size is 1280x1024 (pitch 2048)
(**) I810(0): *Built-in mode "1280x1024"

I tried with and without ModeLine definitions in the Monitor section.


Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-1.6.5-9.2.el5

How reproducible:
Always


Steps to Reproduce:
1. Well, you need the proper Hardware.
2.
3.

Actual Results:
Display mode limited to 1280x1024 which does not fit to the display resolution.

Expected Results:
Not sure, if an upgrade to i810 2.0 fixes the problem.
I think it should be solved for RHEL5 Desktop. An upstream solution is not applicable here.

Additional info:
Comment 1 Werner Gold 2007-05-22 11:08:25 EDT
In the meantime I found out that 915resolution and xorg report different BIOS
modes in their lists.
A workaround, to achieve a proper resolution was to patch a mode that is still
in the aera where both lists match.
But that does not leave enough space to cover all resolutions that I might need:
1400x1050 for the internal display, 1600x1200 or 1280x1024 for external monitors
and 1024x768 for a projector.
Comment 2 Werner Gold 2007-05-22 11:09:58 EDT
Created attachment 155165 [details]
comparison of reported modes (915resolution and xorg)
Comment 3 Matěj Cepl 2007-09-11 20:41:05 EDT
Since this bugzilla report was filed, there have been several major updates,
which may have resolved this issue. Users who have experienced this problem are
encouraged to upgrade their system to the latest version of their distribution
available.

Please, if you experience this problem on the up-to-date system, let us now in
the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as
INSUFFICIENT_DATA. Thank you.
Comment 4 Werner Gold 2007-09-12 04:33:04 EDT
To my knowledge there have been no major updates to the i810 driver in RHEL5.

915resolution is still needed for the workaround.
The workaround still does not work when I need different resolutions (e.g.
projector or additional display)
The "intel" driver still just gives a blank screen.

Current distribution: RHEL 5.1 beta.
Comment 5 Adam Jackson 2012-04-17 16:03:46 EDT
No further hardware enablement updates are planned for RHEL5's X stack.  If this issue remains in RHEL6, please update the affected product version and reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.