Bug 239825 - autoconfig ifcfg-wmaster0 dhcp ONBOOT=yes gets stuck forever
autoconfig ifcfg-wmaster0 dhcp ONBOOT=yes gets stuck forever
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-11 11:54 EDT by Warren Togami
Modified: 2014-03-16 23:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 11:58:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2007-05-11 11:54:19 EDT
- Kudzu autoconfigs iwl3945 creating
/etc/sysconfig/network-scripts/ifcfg-wmaster0 with dhcp ONBOOT=yes.
- During bootup while it starts service networking, it gets stuck forever trying
to do DHCP on wmaster0.

kernel-2.6.21-1.3145.fc7.x86_64
(and many previous kernel versions)
kudzu-1.2.69-1
Comment 1 Bill Nottingham 2007-05-11 12:45:34 EDT
What's hanging? dhclient? ifup? The kernel?
Comment 2 Will Woods 2007-05-12 16:09:51 EDT
It doesn't get stuck forever on my system, just the normal (seemingly endless) 
dhcpcd timeout for devices with no dhcp response.. after that fails boot
continues normally.
Comment 3 Warren Togami 2007-05-18 11:47:22 EDT
> What's hanging? dhclient? ifup? The kernel?
Not kernel, something in userspace.  How can I debug during that point of booting?
Comment 4 Jeremy Katz 2007-05-18 12:14:03 EDT
It's dhclient hanging trying to get a lease.  But you're never going to get an
IP off of the wmaster devices with mac80211 AFAIK, only the wlan devices.
Comment 5 Will Woods 2007-05-18 12:25:46 EDT
Okay, so probably anaconda/kudzu/whatever shouldn't be setting up network config
for wmaster0 then. 

AFAICT this doesn't keep the machine from booting, just delays it a while.
Comment 6 John W. Linville 2007-05-18 13:13:05 EDT
Yeah, wmasterX needs to be ignored.  Maybe kudzu should ignore interfaces with 
UNSPEC link encapsulations (as shown by ifconfig)?
Comment 8 Bill Nottingham 2007-05-18 16:28:19 EDT
Fixed in 1.2.71-1 by ignoring anything where /sys/class/net/XXX/type >= 256,
which is the same test we use in the udev helper for 'don't try to rename this
network device'.
Comment 10 Will Woods 2007-05-21 21:51:28 EDT
We should still investigate why it hangs indefinitely, but since we aren't
bringing up wmaster0 by default anymore this is no longer a release-blocker.

Note You need to log in before you can comment on or make changes to this bug.