Bug 239846 - Can't substitute my-logos for fedora-logos
Can't substitute my-logos for fedora-logos
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-05-11 13:48 EDT by Steve Magoun
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-08 11:28:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Magoun 2007-05-11 13:48:41 EDT
I'm using pungi to create a custom spin of F7T4, and I'm having trouble replacing the Fedora logos 
used in the installer. I created a my-logos package that provides system-logos and removed fedora-
logos from my repository. When I boot my disk, the initial boot screen is text-only and graphical 
installation fails with a python exception and complaints about missing images. I checked the disk built 
by pungi, and sure enough the images (splash.jpg, anaconda_header.png, etc) are missing from the 
isolinux dir and stage2.img. However the my-logos RPM does get included in the repository on the 
install disk.

It turns out the contents of my-logos isn't the problem - it's the name of the RPM. I rebuilt fedora-
logos, changing the name to foo-logos. I get the same results as with my-logos: text-only initial boot 
screen, and graphical install fails.

I traced the problem to anaconda's upd-instroot script, which explicitly includes redhat-logos and 
fedora-logos in the PACKAGESGR variable (PACKAGESGR also includes system-logos, which I thought 
would pick up my-logos). I added 'my-logos' to PACKAGESGR (see patch below ) and rebuilt anaconda. 
That fixed the problem - the installer used my background image and graphical installation worked 
properly.

I expected that replacing fedora-logos with my-logos would be enough; I shouldn't have to rebuild 
anaconda to get my images into the installer.


My workaround, obviously something more general would be better:

[root@dyn-149 anaconda-11.2.0.55]# diff -u scripts/upd-instroot~ scripts/upd-instroot
--- scripts/upd-instroot~       2007-04-20 11:20:50.000000000 -0400
+++ scripts/upd-instroot        2007-05-11 07:38:09.000000000 -0400
@@ -176,7 +176,7 @@
            fonts-xorg-ISO8859-2-75dpi fonts-xorg-ISO8859-15-75dpi
            fonts-xorg-ISO8859-9-75dpi fonts-xorg-100dpi
            fonts-xorg-KOI8-R fonts-xorg-KOI8-R-75dpi fonts-xorg-base
-           xorg-x11-base xorg-x11-ISO8859-15-75dpi system-logos
+           xorg-x11-base xorg-x11-ISO8859-15-75dpi system-logos my-logos
            xorg-x11-libs-data xorg-x11-xfs prelink redhat-logos fedora-logos
            ttfonts-ta ttfonts-bn ttfonts-gu ttfonts-hi ttfonts-pa
            fonts-japanese fonts-chinese fonts-korean fonts-indic fonts-sinhala
Comment 1 Jeremy Katz 2007-05-14 15:08:48 EDT
Yes, right now this isn't very flexible.  We need to rework the entire way that
upd-instroot works, though, to change that.

You _can_ though use the package name 'system-logos' which is pretty neutral
Comment 2 Red Hat Bugzilla 2007-06-11 23:53:08 EDT
requested by Jams Antill
Comment 3 Jeremy Katz 2007-08-08 11:28:05 EDT
As of Fedora 8 test1, you should be able to have anything which provides
"system-logos" work 

Note You need to log in before you can comment on or make changes to this bug.