Bug 239854 - Difficulty finding kernel-largesmp-devel-2.6.9-42.0.3.EL-x86_64
Difficulty finding kernel-largesmp-devel-2.6.9-42.0.3.EL-x86_64
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-11 14:29 EDT by Mike McLean
Modified: 2010-10-06 10:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-06 10:33:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McLean 2007-05-11 14:29:48 EDT
Someone filed an issue with us because they could not find this package (which
was shipped for RHEL4) on rhn. They assumed it was missing. It is not missing,
but the web site does not properly show it in searches.

If I enter 'kernel-largesmp-devel' in the banner search box, select 'Packages'
and submit, I get the search form package and one result. The url for that
result is:
https://rhn.redhat.com/network/software/packages/name_overview.pxt?package_name=kernel-largesmp-devel&channel_arch_ia32=channel-ia32&channel_arch_ia64=channel-ia64&channel_arch_x86_64=&search_subscribed_channels=
Note that this list only shows the ia64 packages.

If use the actual search form with options: kernel-largesmp-devel, 'Name only',
and select the arches 'IA-32', 'IA-64', and 'AMD64', I get a result that looks
the same but has this url:
https://rhn.redhat.com/network/software/packages/name_overview.pxt?package_name=kernel-largesmp-devel&channel_arch_ia32=channel-ia32&channel_arch_ia64=channel-ia32&channel_arch_x86_64=&search_subscribed_channels=
Note that this url shows *no* packages.

Neither of these seems correct. It looks as of the form might be generating the
wrong url. Note in the first url, the option 'channel_arch_x86_64=' is blank
which seems to limit the search. The second url has this problem also and
additionally has 'channel_arch_ia64=channel-ia32' (note the mismatch) which
seems to keep the ia64 packages from showing up.

If I manually correct the url, I get:
https://rhn.redhat.com/network/software/packages/name_overview.pxt?package_name=kernel-largesmp-devel&channel_arch_ia32=channel-ia32&channel_arch_ia64=channel-ia64&channel_arch_x86_64=channel-x86_64&search_subscribed_channels=
Which seems to show the right packages.  Of course, I wouldn't want a customer
to have to use such a workaround.
Comment 1 Grant Gainey 2010-10-06 10:33:57 EDT
Seems to have been fixed at some point

Note You need to log in before you can comment on or make changes to this bug.