Bug 239872 - ARTSd crashing
Summary: ARTSd crashing
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: arts   
(Show other bugs)
Version: rawhide
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-11 19:50 UTC by Shawn
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-15 11:24:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Back trace of ARTS crash (1.97 KB, text/plain)
2007-05-11 19:50 UTC, Shawn
no flags Details

Description Shawn 2007-05-11 19:50:17 UTC
If I run the sound test in system-config-soundcard my sound nVidia Corporation
CK804 AC'97 Audio Controller works correctly however the PNPb006 does not work. 

The output from sysrun.log shows


------- System Config Soundcard Log --------
Fri May 11 13:33:18 MDT 2007

aplay: main:545: audio open error: No such file or directory
cat: /etc/asound.conf: No such file or directory
Running from command-line...
 
------------------------------------------------
There is no asound.conf any where on my system.

If I try the test sound button in Control Center -> Sound System, ARTSd crashes.
This is recreatable at will. 

I am currently patched up to the latest releases of all packages via yum
upgrade. This was a new install of FC7 - Test 4 and then patched up to date.
This was not an upgrade.

I have a separate install of FC-6 on the same machine that works correctly so it
is not the hardware.

The currently installed versions of ARTs are 
arts-devel-1.5.6-2.fc7
arts-1.5.6-2.fc7
arts-devel-1.5.6-2.fc7
arts-1.5.6-2.fc7

i386 and AMD64 I presume.

I have included the back trace that is produced when ARTS crashes and it is
included as an attachment.

The sound card involved is an ASUS onboard system. It is detected by the system as

 class: AUDIO
bus: PCI
detached: 0
driver: snd-intel8x0
desc: "nVidia Corporation CK804 AC'97 Audio Controller"
vendorId: 10de
deviceId: 0059
subVendorId: 1043
subDeviceId: 812a
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  4
pcifn:  0
-
class: AUDIO
bus: ISAPNP
detached: 0
driver: snd-mpu401
desc: "PNPb006"
deviceId: PNPb006

Comment 1 Shawn 2007-05-11 19:50:17 UTC
Created attachment 154566 [details]
Back trace of ARTS crash

Comment 2 Shawn 2007-05-12 21:12:51 UTC
I performed another yum upgrade this morning and it upgraded 100+ packages
includer kernel, glibc, KDE. Arts was not upgraded. Arts is now working
correctly. Issues I was having getting Kaffine and Mplayer to launch are gone as
well. 

system-config-soundcard does not work at all now as it is having issues auto
detecting the sound card. However that is a different bug from what I opened
this ticket as. I will do some trouble shooting and open a new ticket around
that if needed. 

Comment 3 Ngo Than 2007-05-15 11:24:27 UTC
we have same version of arts in FC6 and F7 test4. It seems it's problem in 
other package which has caused the crash in arts.
i close the bug as "not a bug" because arts works fine now.Thanks for your 
report,


Note You need to log in before you can comment on or make changes to this bug.