Bug 239874 - Lockup during boot or immediately after
Lockup during boot or immediately after
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Kernel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-11 16:07 EDT by Leslie Satenstein
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-23 21:53:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The boot messages (83.41 KB, text/plain)
2007-05-12 19:14 EDT, Leslie Satenstein
no flags Details
X windows log file (after Xen reboot) (63.13 KB, text/plain)
2007-05-12 19:17 EDT, Leslie Satenstein
no flags Details
X windows log file (after Xen reboot) (63.13 KB, text/plain)
2007-05-12 19:19 EDT, Leslie Satenstein
no flags Details
/var/log/Xorg.0.log.old (61.15 KB, application/octet-stream)
2007-05-12 19:20 EDT, Leslie Satenstein
no flags Details
Boot messages from FC7 XEN (41.48 KB, application/octet-stream)
2007-05-14 16:45 EDT, Leslie Satenstein
no flags Details
The X windows log file (61.15 KB, text/plain)
2007-05-14 16:47 EDT, Leslie Satenstein
no flags Details

  None (edit)
Description Leslie Satenstein 2007-05-11 16:07:01 EDT
Description of problem:

System is Intel d930 processor on a Intel d945gnt motherboard with X windows
drivers  vesa, i810, and intel (one after the other)

Version-Release number of selected component (if applicable):

kernel 2925.5

How reproducible:

select XEN and watch the system lockup

Steps to Reproduce:
1. Select XEN and anyone of the video drivers indicated.
2.
3.
  
Actual results:

Full system freeze, sometimes cpu fan runs high speed indicating cpu overheating
or cpu in loop, othertimes, only option is power off.

Expected results:

System should boot and run, without dieing.

Additional info:

Please review same problems posted for FC6. Assigned to Ajackson

233843
Comment 1 Daniel Berrange 2007-05-11 18:06:23 EDT
The -2925.5 kernel-xen is known to be utterly broken. Please re-test with latest
kernel-xen & xen RPMs available from, which have fixed at least 4 separate
crash/corruption bugs:

http://koji.fedoraproject.org/packages/kernel-xen-2.6/2.6.20/2925.8.fc7/
http://koji.fedoraproject.org/packages/xen/3.1.0/0.rc7.1.fc7/

NB, you must install both to get working Xen.
Comment 2 Leslie Satenstein 2007-05-12 19:14:55 EDT
Created attachment 154593 [details]
The boot messages

If I sent you the wrong files, or you require additional files, please advise.
Comment 3 Leslie Satenstein 2007-05-12 19:18:00 EDT
Created attachment 154594 [details]
X windows log file (after Xen reboot)

Xorg logfile (current, after crash). Will also include previous one
Comment 4 Leslie Satenstein 2007-05-12 19:19:38 EDT
Created attachment 154595 [details]
X windows log file (after Xen reboot)
Comment 5 Leslie Satenstein 2007-05-12 19:20:26 EDT
Created attachment 154596 [details]
/var/log/Xorg.0.log.old

If you require other logs, please advise
Comment 6 Stephen Tweedie 2007-05-14 11:27:09 EDT
Umm, can you please be a little more precise about exactly what is going on and
which log files correspond to which behaviour?  There are two log files there
labelled "X windows log file (after Xen reboot)"... but after Xen reboots, 
haven't you then rebooted into a non-xen kernel and overwritten the X logs with
new ones from the next boot?

And you haven't told us if the behaviour changed with the new .8 kernel.  The
kernel boot messages attachment shows two separate boots, one with .8 and one
non-xen, but both last until the same lines (they both end at gconfd xml
warnings), so it's really unclear whether you are still seeing different
behaviour from xen and non-xen.
Comment 7 Leslie Satenstein 2007-05-14 12:21:12 EDT
I am not an linux guru, so I thought that since your updated XEN runs to the
lockup point, that you would want to see the message log, and the X-windows logs
to where it locked up.

In attaching the files, I did accidentally, due to a little buglet in firefox,
resend one file twice, because FF did not return to update the prompt. 
There should only be 3 files.  2 for X and messages.

If I sent the wrong ones, or incomplete please advise me, how to proceed (email
me separately if you wish), and I will do for you what you need to have done.

My background is more in computer system architecture (business systems, and in
mathematical modeling,) and while I never compiled a kernel, I did program for
years in C. 


Comment 8 Leslie Satenstein 2007-05-14 13:32:52 EDT
You asked..
Umm, can you please be a little more precise about exactly what is going on and
which log files correspond to which behaviour?  
I replied...
I zeroed the messages file and the x-windows file. and rebooted with non-XEN in
order to create the attachments. Just in case, I also included the (-1) version,
a previous X log file. I presume that the X log file after the reboot back to
normal made the backup version of the previous log file.

There are two log files there
labelled "X windows log file (after Xen reboot)"... but after Xen reboots, 
haven't you then rebooted into a non-xen kernel and overwritten the X logs with
new ones from the next boot?

And you haven't told us if the behaviour changed with the new .8 kernel. 
The behaviour did change. 

I replied
I saw a cleaner boot with one message that was the result of an assert() call
disappear. I was able to log to gnome for about 2 minutes. When I retried after
that crash, the system appeared to lock up before the gnome prompt was
presented. So, I really cannot tell you more than that. 

I will clear out the three log files (X windows and messages) and do the following:
1) reboot with XEN, and attempt to log into the system.
I will try to use the system until a lockup occurs

I will then boot with my alternate FC6 and copy to a safe place those log files,
I will tell you exactly what happened.

If there is a log file that I am sending that is not the right one, please
advise me. 

  


The
kernel boot messages attachment shows two separate boots, one with .8 and one
non-xen, but both last until the same lines (they both end at gconfd xml
warnings), so it's really unclear whether you are still seeing different
behaviour from xen and non-xen.

I reply again
I will redo the test.
Comment 9 Leslie Satenstein 2007-05-14 16:45:49 EDT
Created attachment 154688 [details]
Boot messages from FC7 XEN
Comment 10 Leslie Satenstein 2007-05-14 16:47:22 EDT
Created attachment 154689 [details]
The X windows log file

If there are other things for me to do to help you, please advise.
Comment 11 Leslie Satenstein 2007-05-23 21:53:28 EDT
Currently 
	kernel-xen-2.6.20-2925.9.fc7.i686.rpm	22-May-2007 06:04 	 16M
[ ]	kernel-xen-devel-2.6.20-2925.9.fc7.i686.rpm	22-May-2007 06:03 	14M

Broke the version that partially worked. Now, somewhere in the boot process, the
keyboard, mouse and power interrupt switch are lost.  No Gnome, no keyboard
response, bad bed bad.  

It also resulted in some common files with the preceding version (8) so that
neither boots on my system.

Note You need to log in before you can comment on or make changes to this bug.