Bug 239886 - Autotools tool actions currently erroneously default the CWD
Autotools tool actions currently erroneously default the CWD
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnston
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-11 17:51 EDT by Jeff Johnston
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-11 17:58:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Johnston 2007-05-11 17:51:16 EDT
When the aclocal, automake, or autoconf Project menu actions are chosen, the
tool is being run for the project directory.  This is incorrect.  The tool
should be run with the current selected directory being the CWD.
Comment 1 Jeff Johnston 2007-05-11 17:58:47 EDT
Fixed in next release.  The CWD is now correctly calculated and used when the
commands are executed.  The CWD is displayed for aclocal and automake when
prompting for the options as this has bearing on the actual options used (e.g.
relative directories).  A new success dialog is now shown for all 3 tools.  For
autoconf, the success dialog shows the CWD it was successfully run in.

Note You need to log in before you can comment on or make changes to this bug.