Bug 239905 - F7t4 suspend regression
F7t4 suspend regression
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nigel Cunningham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-12 04:05 EDT by Philip Frampton
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: f7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 17:48:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Frampton 2007-05-12 04:05:30 EDT
Description of problem:

Suspend to RAM no longer works. Suspend/resumes works out of the box on FC6 but
fails on F7t4. The laptop is HP nx6125 with ATI X200M gfx card. The gfx driver
is the xorg open source driver. The problem is with resuming. The laptop starts
to resume, the fans start up and caps lock comes on (not on when suspended) but
then no further action happens. Machine does not respond to power button,
Ctrl-Alt-Del, Ctrl-Alt-Backspc or caps-lock.

Version-Release number of selected component (if applicable):
0.99-1 and 0.99-2

How reproducible:
Suspend/resume
 

Additional info:

I would like to help debug this but I have had no success trying "pm-suspend
--quirk....". If someone could work out the default suspend options for and ATI
card on FC6 and tell me how to pass those to pm-suspend I can check if this is
the problem.

The fact that the machine becomes unresponsive after suspend does not suggest it
is simply failing to turn on the backlight.

Thanks in advance for any help.
Comment 1 Nigel Cunningham 2007-05-18 18:41:40 EDT
Which kernel are you using, please?

Reassigning to me as this looks like a kernel issue.
Comment 2 Philip Frampton 2007-05-20 12:31:16 EDT
I had no trouble with any of the kernel 2.6.18 to 2.6.20 on FC6 (and updates).
The suspend problem happens since F7T4, starting with the 2.6.20-1.3104. I have
also tried 2.6.21 - 3116, 3149, 3163 all give the same problem.

I agree that it might be a kernel problem as from all the logs there is no sign
of the system recovering from resume. No blind login, no response to caps lock,
ctrl+alt+delete (or backspace), no response to the power button. When I do force
a reboot it does fsck the filesystem on restart.

On FC6 I was using no kernel options apart from having a framebuffer (radeonfb
1400x1050). And I have tried F7t4 with and without framebuffer. I have also
tried "noapic nolapic" - something I did need in earlier kernels. I have also
tried with bcm43xx and bcm43xx_mac80211 blacklisted.

Is it possible (and even helpful) if I recompile a FC6 kernel srpm on my F7t4
box? Also, I tried a vanilla 2.6.21 kernel on FC6 and I know that worked.

Thanks for looking into this.
Comment 3 Nigel Cunningham 2007-05-21 02:19:27 EDT
Could you tell me what the last kernel version was that worked?

Glad to be of help.
Comment 4 Philip Frampton 2007-05-21 04:39:50 EDT
When I removed FC6 I was using kernel-2.6.20-1.2944.

Is there anything I can do to get more debug information for you?
Comment 5 Nigel Cunningham 2007-05-21 20:13:13 EDT
I have a 200M graphics card here too, so will try the kernel here. Maybe I can
reproduce it locally and find the cause.
Comment 6 Nigel Cunningham 2007-05-22 23:35:14 EDT
I haven't been able to install F7T4 under Vmware (other issues). I have however
heard that Dave Jones has some patches queued to fix suspend regressions.
Hopefully they'll address your issue.
Comment 7 Richard Hughes 2007-05-24 06:30:30 EDT
Can you also check http://people.freedesktop.org/~hughsient/quirk/ for common
problems please. Thanks.
Comment 8 Philip Frampton 2007-05-24 06:50:13 EDT
Thanks for the suggestion but I've already worked through the stuff on your site.

I've also tried the F7t3 kernel (also fails to resume). I'm planning to try the
F7t2 kernel later today.

I tried using the RTC trick on Richard's website to identify what might be
failing on resume and line after the Magic number.... was
/drivers/base/power/resume.c line 62.

It doesn't seem to be a kernel thing as I get no back trace, but similarly the
laptop is reported working with Hal and Mandriva 2007.
Comment 9 zuka 2007-06-06 21:46:34 EDT
I've got a Dell Inspiron 700m. Suspend / resume worked great with FC6.

Just did clean install of 2.6.21-1.3194.fc7 i386 and it suspends fine. On 
resume screen doesn not light up (no backlight) caps and numlock flash on and 
off and system is unresponsive to keyboard / mouse / powerbutton. I have tried 
intel and i810 graphics drivers and the "pm-suspend --quirk...." doesn't seem 
to make any difference.
Comment 10 Richard Hughes 2007-06-07 09:50:42 EDT
Zuka, you are describing a different bug. Please see
http://people.freedesktop.org/~hughsient/quirk/index.html
Comment 11 Nigel Cunningham 2007-06-12 01:11:12 EDT
Phil, any progress with this? I tried suspending to ram with current Rawhide a
short while ago (kernel 3218), and it worked ok. The display doesn't come back
on until X reinits it, but it does work.
Comment 12 Philip Frampton 2007-06-21 16:57:43 EDT
Thank you for the help. I think I've got it working fine now - it turned out to
be the firewire module(s) causing the problem. I rmmod'd them and it worked
(tested twice in a row). I'm in the process of learning how to get suspend to
unload them.

The only problem I have now is that after resume the virtual terminals are
corrupted. I'll look and see if there is a simple fix.

Once again, thanks for the help.
Comment 13 Philip Frampton 2007-06-21 18:12:55 EDT
I've enabled a framebuffer and this avoids the problem, VTs are nolonger corrupted.
Comment 14 Richard Hughes 2007-06-22 05:06:36 EDT
(In reply to comment #12)
> I'm in the process of learning how to get suspend to
> unload them.

See http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-advanced.html,
yell if it's unclear.

(In reply to comment #13)
> I've enabled a framebuffer and this avoids the problem

How did you do this? I'll add it to the suspend FAQ.

Richard.
Comment 15 Philip Frampton 2007-06-22 05:19:48 EDT
Thanks Richard. I followed the instructions and it works fine - unloading
fw_ohci, etc. Successive suspends work great. You might want to add the listing
the fw_ohci fw_core in suspend modules to the FAQ as it seems to be a common
problem and one that doesn't have any clues indicating it. The trick to identify
bad modules didn't reveal anything - I just tried rmmod'ing the firewire stuff
as I saw it on planet.fedora.

For the framebuffer, I added "vga=836" which I found on a website for a similar
laptop. It's 1400x1050 not sure what depth. Anyway with that running the VTs are
still sane after resume. Without it, the effect is like the screen melting -
something I'm unfortunately familiar with from my other laptop with the new
intel driver. I think it's something to do with the timings. Presumably it's a
kernel bug as X is fine. Note - I do have the horrible ATI X200m graphics card.
Comment 16 Richard Hughes 2007-06-25 17:43:26 EDT
>You might want to add the listing the fw_ohci fw_core in suspend modules to the FAQ

Done, thanks.

>Successive suspends work great...

Cool, I'm glad we got it going. Thanks!
Comment 17 Nigel Cunningham 2007-06-25 17:48:59 EDT
Philip, I have a 200M graphics card too. For suspend-to-ram, I need the s3bios 
& s3mode hacks (both of them). You might need them too.

I'll close this bug since the original issue is now fixed.

Note You need to log in before you can comment on or make changes to this bug.