Bug 239925 - device-mapper detects possible recursive locking during boot
Summary: device-mapper detects possible recursive locking during boot
Status: CLOSED DUPLICATE of bug 204311
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Milan Broz
QA Contact: Corey Marthaler
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-12 15:59 UTC by Kevin Cozens
Modified: 2013-03-01 04:05 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-12 17:38:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Extract of /var/log/dmesg showing problem with device-mapper. (3.02 KB, text/plain)
2007-05-12 15:59 UTC, Kevin Cozens
no flags Details

Description Kevin Cozens 2007-05-12 15:59:08 UTC
The device-mapper seems to be running in to some sort of problem during the boot
of F7t4 x86_64 on an HP m7680n computer. The output from rpm -q on device-mapper
shows device-mapper-1.02.17-7.fc7. The problem occurs on every boot of the computer.

I have attached an extra of the /var/log/dmesg file showing the messages from
device-mapper. I included a few extra lines so you can see where the problem
occurs in the boot process.

Comment 1 Kevin Cozens 2007-05-12 15:59:08 UTC
Created attachment 154586 [details]
Extract of /var/log/dmesg showing problem with device-mapper.

Comment 2 Milan Broz 2007-05-12 17:38:44 UTC
This is known kernel device-mapper problem, actually this is "warning only"
caused by recursive dm_requests (mostly when using dm stacked devices) calls
without properly notifying lock validator about lock nesting (in the case of
stacked devices it is false positive but this issue still need further
investigation).




*** This bug has been marked as a duplicate of 204311 ***


Note You need to log in before you can comment on or make changes to this bug.