Bug 239934 - Shredding patch for logrotate
Summary: Shredding patch for logrotate
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: logrotate   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Smetana
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-12 18:47 UTC by Peter Eckersley
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-23 12:17:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to make logrotate call GNU shred (6.52 KB, patch)
2007-05-12 18:47 UTC, Peter Eckersley
no flags Details | Diff

Description Peter Eckersley 2007-05-12 18:47:51 UTC
Description of problem:

Hi!  We have a project here at EFF to ensure that free software systems
implement users' and sys admins' policies on data retention and deletion
securely.  We're sending patches :)  Attached is one that has logrotate call 
shred from the GNU fileutils when it deletes log files.  Conf file options are
available to turn this off and on for various logs, and to change the number of
overwrite passes that shred makes.

It'd be great if you could include this in future releases of logrotate!

Thanks,

Peter Eckersley

Comment 1 Peter Eckersley 2007-05-12 18:47:51 UTC
Created attachment 154589 [details]
patch to make logrotate call GNU shred

Comment 2 Tomas Smetana 2007-05-14 06:52:56 UTC
Thanks for the patch.  I'll go through it, but at the first look it seems to be
OK.  The devel branch is freezed and this will unlikely find its way to FC7
release, but might be included in one of the updates.

Comment 3 Tomas Smetana 2007-05-14 10:41:01 UTC
I've adapted the code for logrotate-3.7.5 and turned the new option off by
default. The patch was commited.


Note You need to log in before you can comment on or make changes to this bug.