Bug 239964 - source rpm doesn't build with ed 0.3
source rpm doesn't build with ed 0.3
Status: CLOSED DUPLICATE of bug 227902
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-13 10:01 EDT by Vilius Šumskas
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 11:13:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vilius Šumskas 2007-05-13 10:01:21 EDT
Description of problem:
postfix source rpm doesn't build with ed version 0.3. It stops on the lines:

ed $RPM_BUILD_ROOT%{postfix_config_dir}/postfix-files <<EOF || exit 1
%s/\(\/man[158]\/.*\.[158]\):/\1.gz:/
%s/\$config_directory\/aliases:f/\#/
w
q
EOF
on postfix.spec with the error number 17479. I'm not sure is this a bug in the 
ed or with this regexp but ed in fc5 worked fine.


Version-Release number of selected component (if applicable):
postfix-2.3.3-2

How reproducible:
Always

Steps to Reproduce:
1. rpm -i postfix-2.3.3-2.src.rpm
2. cd /usr/src/redhat/SPECS/
3. rpmbuild -bb postfix.spec
  
Actual results:
ed quits with error number 17479

Expected results:
It should build the rpm binary package.

Additional info:
Also tested with ed-0.2-38.2.2 and it worked fine.
Comment 1 jean-noel 2007-07-26 12:01:09 EDT
I have exactly the same problem
I downgrade to ed-0.2-38.2.2.i386.rpm and it is building well

PS : I think 17479 is the file size of $RPM_BUILD_ROOT/etc/postfix/postfix-files
Comment 2 Thomas Woerner 2007-09-24 11:13:22 EDT

*** This bug has been marked as a duplicate of 227902 ***

Note You need to log in before you can comment on or make changes to this bug.