Bug 239966 - Vim buffer too short
Vim buffer too short
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-13 11:17 EDT by Juan Manuel Borges Caño
Modified: 2008-02-25 11:08 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-25 11:08:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Juan Manuel Borges Caño 2007-05-13 11:17:02 EDT
Description of problem:

vim cut and paste buffer is limited, I used vim in another distributions and it
is not limited, at least not with a small value like the one in fedora. I think
it is dangerous for developers that cut and paste, since the paste isn't the
same as the cut, resulting in LOST OF DATA.

Version-Release number of selected component (if applicable):

vim-minimal-7.0.235-1.fc6
vim-common-7.0.235-1.fc6
vim-enhanced-7.0.235-1.fc6

How reproducible:
always?

Steps to Reproduce:
1.select a 'big' region of text (100 lines +/-)
2.cut it
3.paste it
  
Actual results:
Lost of data in the paste

Expected results:
The paste should be the same as the cut, respecting user data.

Additional info: Using fedora 6 with updates
Comment 1 Juan Manuel Borges Caño 2007-11-09 17:01:47 EST
The status in f8:
 I can cut and paste big regions like 10000 lines in the same file
 but if I cut 10000 lines of one file, close it and open another file, when I
try to paste the region it only pastes 50 lines.

 Do you know if it is a buffer configuration issue at compilation or
configuration, or a vim limitation?

 I did a little research on the subject and nothing appears, I'm starting to
doubt it but I think I was able to paste a more large region between files.
Comment 2 Karsten Hopp 2008-02-25 11:08:31 EST
this looks like a limitation of vim when it is compiled without xterm_clipboard
support.
Workaround: use gvim  or gvim -v  and the special yank buffer *
(type :h clipboard   for some help about this buffer)

Note You need to log in before you can comment on or make changes to this bug.