Bug 239969 - Software Updater Crashes
Summary: Software Updater Crashes
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-13 16:38 UTC by J. Alexander
Modified: 2008-01-26 13:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-26 13:41:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash Dump (1.34 KB, application/octet-stream)
2007-05-13 16:38 UTC, J. Alexander
no flags Details
Crash dump from Software Updater, "no such column: checksum_value" (2.31 KB, text/plain)
2007-05-13 18:54 UTC, Martin A. Boegelund
no flags Details

Description J. Alexander 2007-05-13 16:38:22 UTC
Cannot use Software Updater or yum update.  Both crash.  Crash dump attached. 
This is a brand new install of Test 4 of Fedora 7 on an AMD 64.

How reproducible:  Any update causes the crash.


Steps to Reproduce:
1.  Reboot
2.  Attempt updates install through pup or cmd line yum update
3.
  
Actual results:
Crash

Expected results:
Updates applied successfully

Additional info:

Comment 1 J. Alexander 2007-05-13 16:38:22 UTC
Created attachment 154610 [details]
Crash Dump

Comment 2 Martin A. Boegelund 2007-05-13 18:52:18 UTC
I can't use Software Updater either. And yum doesn't work either.

First I had a crash, where the dump indicated that the livna repository was a
problem. So I removed livna.
Then I had a crash, where the dump indicated that the freshrpms repository was a
problem. So I removed freshrpms.
Then I had a crash, where the dump indicated that a column ("checksum_value")
was missing from sqlite.

I've attached a crash dump from the 3rd crash.

My system is a fresh update from FC6 to FC7Test4. Hardware is i386/Celeron 2MHz
processor.

Martin


Comment 3 Martin A. Boegelund 2007-05-13 18:54:07 UTC
Created attachment 154613 [details]
Crash dump from Software Updater, "no such column: checksum_value"

Software updater crashes in first attempt to update system.

Comment 4 Martin A. Boegelund 2007-05-13 22:37:00 UTC
I think I found a solution that works in my case:

First I downloaded rpm-packages for
- yum
- yum-metadata-parser
- yum-updatesd
from the development repository at
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/os/Fedora/

Then I installed these packages with an rpm command-line transaction:
# rpm -Uvh yum-3.1.7-2.fc7.noarch.rpm yum-metadata-parser-1.1.0-1.fc7.i386.rpm
yum-updatesd-3.1.7-2.fc7.noarch.rpm

Then I ran yum to update my system:
# yum update

And it looks like it works.


Comment 5 J. Alexander 2007-05-14 09:30:01 UTC
Updating yum works like a charm.  Updates install successfully.  Thanks for the
info Martin.

Comment 6 Peter van Egdom 2008-01-26 13:41:50 UTC
Thank you for the report. However this has been reported to the incorrect
component. Reassigning from "up2date" to "pirut". 

Closing bug as per comment #4 and comment #5.


Note You need to log in before you can comment on or make changes to this bug.